F2 in Excel no longer working (Ctrl-U)

I have created a F2 macro in the past to simulate Ctrl-U in Excel, to much success. However, I just tried it again recently and it’s not working. It simulates a ‘cut’ action, for some reason.

Other actions, such as F4 to simulate CMD-T (to toggle between relative/absolute references) works just fine.

However, other CTRL- actions fail to work as well (e.g. CTRL-I for insert cells).

Thoughts on solving this?


1 Like

That is strange Control+U works just fine here to enter info at the end of the line. I use that key command several times a day with shift+option+command+[ and ] for start of cell and end of cell text. I haven't converted these over to Keyboard Maestro from QuicKeys just yet.

Okay I just added them to Keyboard Maestro and tried it with F2 and is working just fine here.

Excel Go to Cell Start and End.kmmacros (42.8 KB)

I believe F2 is Cut by default, so my guess is your macro is not active at all, probably because the macro group targeting is no longer correct, perhaps because an application or OS update broke the connection to the application. Try reselecting the target application in the macro group.

Keyboard Maestro http://www.keyboardmaestro.com/ Editors’ Choice Award winner.
Macros for your Mac http://www.stairways.com/ http://download.keyboardmaestro.com/
Join us on the Keyboard Maestro forum http://forum.keyboardmaestro.com/

Have you checked your system preference settings for Keyboard? There have been occasions when I had to go back and disable re-enable stuff.

Any new updates to your system? or MS Office?

Also check auto text entries for any strange stuff.