Feature request: Improve Conflict Palette colors

Continuing the discussion from Suggestion: Rename "Conflict Palette" to Make It Sound More Positive:

and a similar thread I made not so long ago.

@peternlewis another vote to improve the Conflict Palette to have higher legibility.

Just adding a white background option would make it better on the eyes.

Domo arigato

You have control, over the display of the Conflict Palette in the Palettes preferences.

Hi Peter, I must be doing something very dumb because I can't find any customization option in
Preferences > Palettes > Palette Styles > Conflict Palette

I can only see an option to switch between themes like Evergreen, Evening, etc

EDIT: Found this option in the Wiki:

is that the only way I guess?


@gerrie try this in Terminal:

defaults write com.stairways.keyboardmaestro.engine CustomPaletteTheme -string '{
"TitleBackground":{"c1" : [0,0,0], "c2" : [0,0,0], "angle":0},

That will change the Custom palette to look like this:

Screen Shot 2020-12-29 at 10.19 AM
Screen Shot 2020-12-29 at 10.26 AM
Edit the line "TextHighlighted":[360,100,100], if you want to change the highlighted color from Red to something else.

@hello, Thanks for the pointer to the defaults command. I will play with the palettes colors later. I know it will take multiple trial and error steps to get something satisfying with this method.

At a quick glance through manual page I was also pleased to find that I can control the timeout on Display Large Text. Now, if I could only set a maximum text size so I don't have a short word filling the screen vertically.

1 Like

@gerrie I think there was a thread about using Stickies.app to display large text,
but here's an alternative:

Thanks for the reference, but I very specifically want to use the in-your-face and auto-retire features of Display Large Text. It’s just that for short words, the text is so large it’s almost hard to read. I want a notification that’s short (in both senses of the word) and sweet.

I don't want to have to close a dialog (or any other window). The notification option doesn’t work for me. It’s too small, and not always even noticeable on my large monitor with reminders and other notifications appearing regularly.

It’s possible that being able to auto-retire more quickly may solve most of my problem.


1 Like