Filemaker Pro not activating~

2017-11-24 04:49:21 Action timeout exceeded. Macro “zz 0449 Update Outstanding Invoices” cancelled (while executing Activate FileMaker Pro Advanced).

I run numerous 'Time of Day' Macros in the early AM.
Most of them perform scripts in Filemaker Pro.
I have the system prefs energy saver set to 'wake up' at 4:48 everyday just as a precaution.
It has worked fine for the last year or so, although once in a blue moon, it would not trigger and I would have to trigger them manually.

  • Filemaker Pro is always running BTW
    The last 4 days in a row, they have not triggered and I get the above engine.log report
  • Any clues?

zz 0449 Update Outstanding Invoices.kmmacros (10 KB)

Hey Troy,

I’d put a pause after Wake Screen.

I’d put a Pause-Until after Activate FileMaker Pro Advanced.

I’d also put in actions in various places to write progress to a log, so I’d have some debug info.


1 Like

By any chance did you upgrade FMP about 4 days ago?

I have seen cases where when an app is updated, its system ID will change. Thus, the KM Macro which has an Activate FMP action is still using the old ID.

So, just as a precaution, edit your macro, delete the current Activate and insert a new one, selecting "FileMaker Pro Advanced".

=), no, no updates in the last few days, but excellent inquiry! -
For testing, I disabled the ‘activate Filemaker Pro Advanced’ action and put a simple AppleScript to activate FMP.
This morning all 9 time of day macros ran as they should.
Great suggestion about ‘resetting’ the ‘activate FMP’ step, I may do so or just leave the AppleScript…
Thank you for your time and input…

1 Like