Firefox icon in the mac dock

i used a lot of desktop in the mac
in macos mojave
desktop 1 until desktop 16

and a lot of time i open Firefox in desktop 1
and than when i in desktop 5
i click in the Firefox icon in the mac dock
it take me to the desktop 1 Firefox

if you can help me
i want some solution
i want to go to empty desktop
then click in the Firefox icon in the mac dock
and then new windows of Firefox will open
and the mac don't take me to the desktop 1
where is already have Firefox window open

please i just want to click in the Firefox icon in the mac dock
and don't click on open new window on Firefox icon menu in the mac dock

if you can solve this issue
maybe i can use this with more app on the dock

Your issue doesn't look like a Keyboard Maestro issue. In the dock, right click the Firefox icon, click Options and under Assign To - choose All desktops.

My guess is it's assigned to Desktop 1.


maybe Keyboard Maestro can fix that
your solution is good but i am sorry
it not solve my problem as i presented

Ok. I think I now understand what you want. I couldn't wrap my head around it. You want different Firefox windows to be on different Mac Desktops. I'll have to research that but I'm thinking one way to accomplish this is to have 2 different Firefox installs. Name the second one and you can have that one spawn to a new desktop. I'm not sure. Have you searched Google?

Your answer lies here.

Assign apps to spaces

If you assign an app (or System Preferences) to a specific space, the app will always open in that space.

  1. On your Mac, press and hold an app’s icon in the Dock. You may need to first open the app to see its icon in the Dock.
  2. From the shortcut menu that appears, choose Options, then choose one of the following:
  • All Desktops: The app opens in every space.
  • This Desktop: The app opens only in the current space. If you use the app full screen, it appears in its own space.
  • Desktop on Display [number] : The app opens in the current space on a specific display (if more than one display is available).
  • None: The app opens in whichever space you’re using at the time.

By default, when switching to an app, the desktop automatically switches to a space that has open windows for the app. For example, if you create a new TextEdit document in Desktop 3, but TextEdit windows are already open in Desktop 2, your new document opens in Desktop 2. To change this setting, choose Apple menu > System Preferences, click Mission Control, then deselect the checkbox for switching.

This allowed me to open a new window on a different desktop without taking me to the initial desktop. Make sure in my first example, make sure you right click Firefox in the dock, option and select assign to none. I think this is what you wanted to do.

Good luck.

yes i search it

you can see that i am not selected
the "when switching to an .............. "
so it should not take me to the already open Firefox window open in another desktop
but it do take me
and do not open new windows in the current desktop i am in

Uncheck Displays have separate spaces.

Is this what you want to do? See video link below.