[Fixed] Clipboard data in latest Evernote (6.0.3) is not called by Keyboard Maestro

Hi there,

For below case, I have one shortcut to change select words to make uppercase by KM,

Type the ⌘C Keystroke
Filter Clipboard with Uppercase
Type the ⌘V Keystroke

Recently after I update Evernote to v.6.0.3, I found Macros related to the clipboard get return “No Text In Clipboard” in Evernote.

I guess It’s due to latest update of Evernote, since it goes to 6.0 version.

I may need support from Keyboard Maestro, is there any alternative solution to fix the problem?

Kind Regards!

Its hard to know for sure as I don’t use Evernote. You could ask the developers what changed.

Things I would try would include:

  • Add a Pause after the Command-C.
  • Add a Filter Clipboard: Remove Styles after the Command-C (this forces Keyboard Maestro to read the plain text of the clipboard, although that should be read anyway).
  • Desperation: Add a Switch to Finder, Switch to Last Application action after the Command-C to force the clipboard to be updated.

Trying your macro in Evernote, I have the same problem. However, I find that Popclip (http://pilotmoon.com/popclip/) works perfectly. I guess that there is something about the way KM copies the text is different from Popclip but I have no idea what it might be.

I just downloaded the latest Beta for Evernote (6.0.4) and your macro still doesn’t work in that. However, I created a one line uppercase text action in Automator to work as a service and that does work.

Since Automator and Popclip both work in Evernote it looks like something Peter might be able to address.

Dear Peter & Chris,

Thank you for your support here, after my several trials, I use AppleScript to read the selected/copied, text. and then goes with Keyboard Maestro for normal procedure.

It's workable now.

Kind Regards!
Donnel Lu

Thanks for this, I was beating my head against the wall on the problem for days.

Couple of thoughts:

  1. Ctl C and Ctl V keystrokes work just as well, I’d imagine you get menu flashes with the menu selection actions.

  2. When I started messing with longer text selections I was getting old selections left in the variable when it returned from the applescript. It may be that the script is backgrounding. I put the script in a separate macro and called it as an action and it seems to be OK now but I can’t be sure.

Again, thanks.

Donnel, many thanks for your workaround with doing an KM “COPY” from selected text in Evernote.

I would like to save your custom “Execute AppleScript” as a KM Action, in the Action selection list. I’ve searched everywhere and can’t figure out how to do this? Any ideas?

Donnel, thank you again for this solution.

I have tried to turn it into a reusable Macro.


By the way, this bug is also in Slack and i suppose a bunch of other web app. I’m using the Desktop version of Slack and have the problem. Using the Menu trick worked for me too. I guess I’m reporting this more so that Peter can investigate what might be the problem and why the command+C way of doing this doesn’t work, even if it’s in the menu and “should” work.

Thanks for this tip Donnel!