Found Image issue with Big Sur 11.4 and KM 9.2?

Upgraded to the latest release of Big Sur (11.4) and all my Macros that rely on Found Image to pause or click are no longer working. I restarted and tried different apps (e.g. Firefox and MoneyDance) and am still running into issues.

When I first had the issue I copied an image from a website and put it into a macro replacing the existing image (thinking it was slightly changed) and no matter how I put the fuzzy slider KM reports the found status as false. This is true across many images, websites and apps. Restarting the Mac didn't help.

Kinda at a loss and I don't see others reporting the issue. Am I the only one?

See Troubleshooting -- KM Wiki.

Also, please upload a simple, typical macro that no longer works under Big Sur.
You might try creating a new Macro with found image to see if that works.

Reinstalled KM 9.2 and ran the interactive help but no joy.

One of the examples is looking for an image on this website. The long macro is paused waiting for an image to appear.Test.kmmacros (21.5 KB).

As you can see in this screenshot

the image that I copied is on the screen but the Pause Until still shows as False. It remains false even if I bring the browser window to the front (though that shouldn't make a difference with "all screens"). Moving the slider doesn't help.

This is what is happening to all my macros that are waiting for an image.

I had this happen also and had to recopy and paste images I wanted found. maybe a computer restart will help because you have already tried new images.

Thanks for confirming I'm not insane. Unfortunately tried the restart and no luck.

Check the record screen privacy setting. This last Big Sur update randomly revoked permissions from some apps. My KM lost screen recording and full disk access until I reenabled them.

Thanks for the tip @kvanh
I experienced the same problem after updating to Big Sur 11.4, and after toggling screen recording permission for Keyboard Maestro the problem was resolved.

Thank you!!! That was it. It wasn't KM itself that had lost the permission but KM Engine.

Screen Shot 2021-05-28 at 7.03.16 AM