Gesture trigger doesn't work

I can't manage to make this simple macro work. :face_with_monocle:
Can anyone help?
Thanks a lot,

I’ve always used gestures with a modifier key (mainly a control key). It’s more dependable, to me, that way. Otherwise, it’s just consistent enough with the way I work.

I wonder if such one finger gestures (without modifiers) should work on the trackpad at all. Every movement of the cursor could then trigger something.

Anyway, if you want to do a lot with gestures, you should try BetterTouchTool.

thanks , I'll give it a try

doesn't work with a modifier neither :confused:

Strange, this works here.

Any error messages in the Log file? (Help > Open Logs Folder > open Engine.log in a text editor.)


I assume you think it's not working because you don't see a "z" displayed.

If that's the case you might want to check that notifications are enabled for KM on your Mac since that's been a cause for a few supposed problems in the past.

Make sure the macro is in a Group that is either the Global Group or a Group with that application.

For Example:

Screenshot 2024-04-05 at 9.05.39 AM

Also, select the macro and try the Keyboard Maestro Interactive Help under the Help Menu.

Nice one! I had them activated though.

My macro is now working if I had a modifier condition !

with a modif' it works now :slight_smile:

you could see in the upper rigth corner of my screen shot that my macro is in the global group :wink:
thanks though!

Hi, I now solved my issue by adding a modifier. I can work with that . :slight_smile:

Shrug. I didn't even look up there. Glad the modifier suggestion worked.

1 Like

Here's a good macro to help you test the gesture triggers. I find that when there's only one gesture, like move mouse left, the trigger won't (ever) work, but if I have multiple gestures it does (usually) work.

1 Like