Help To Find & Click Ok Button Of Google Chrome Extension

I use the KM macro below to execute the Google Chrome extension to overwrite files in my drive. Unfortunately, I'm unable to get KM to find and click the Ok button of the pop up graphic or box or window or whatever it is shown below that executes the final action to complete the drive overwrite. I have to manually click on the Ok button! Any suggestions for accessing the Ok in the pop up box using KM?

Keyboard Maestro “Overwrite Google Drive Fedd Releases File” Macro

Overwrite Google Drive Fedd Releases File.kmmacros (179 KB)

At the end of your actions list add an action to “type text” and have Keyboard Maestro type the RETURN/ENTER key. See if that works.

Thanks Tunes,

Good idea! I had been so intent on using the Interface Control actions I neglected to consider your approach. Unfortunately, neither find image, entering text, simulating keys, typing keystrokes or pressing a button actions accesses this box and its Ok button. None of these attempted actions seemed to have the right “focus” for this button on the screen. Their actions appear to impact the background screen, if that makes sense, where this box and button is in the foreground.

Does anyone have any other suggestions?

Does the Move and Click action work when you run it on its own? Test it with a "Just Move" as its own macro. When I try it with your source image it properly identifies the button.


Thanks for the suggestions! I believe it has led me to understand that the problem is not with the find image action to locate the Ok button, but a different problem which I don’t know how to solve.

I was able to have a separate test macro triggered by the F2 function key to “Just Move” to the Ok button. I was even able to Move & Click the Ok button from the separate macro triggered by F2. However, I was not able to invoke the test macro from the original posted macro (not even asynchronously). It seems that the original macro is held up and unable to execute any further actions once the Ok button pop up appears.

Has anyone else seen this behavior and overcome it? Is this a Javascript issue?

Posting from my phone so I can’t tinker, but maybe moving to a pure Pause of a safe duration instead of Wait for Chrome to Finish Loading, at least in the last instance of that action, might help? Thinking that if you Pause long enough to ensure the button has appeared, and successfully click the button, you can avoid whatever is actually causing the issue. (Since I don’t know what the issue could be).

Purely speculating. I don’t know anything about JS and very little about KM.


Man, I had been stumped by this issue for so long and now you've cracked it!!! Thank you very much for your speculations. I made the modifications shown based on your suggestions and it worked! Looks it was/is simply user's lack of understanding.

I hope I can even partially help you or someone at this forum as I've been helped!

Keyboard Maestro Actions

Keyboard Maestro Actions.kmactions (27 KB)

Excellent! I suspect there probably is an underlying problem with Not recognizing if chrome has loaded, but I’m glad this works for you now.

You’ve already helped me, though. I would have literally put a “pause for x seconds,” and only on revision days or weeks later realized I could use “pause until found image.” Silly, since I said It myself (“long enough to know the button has appeared”) it still wouldn’t have occurred to me until later. So thank you!

Something that helps me sometimes is to adjust the blur (the “e” with the slider).
Also have you tried the “Get” Button and the “Go” Buttons? I use them all the time when a specific macro gets out of whack. Just click “Get” then place your cursor at the point you want to capture and wait for the count down. Then click on “Go” to see the actual location it’s captured. Very handy.

Looks like you have a solution using Found Image, but if you’d like a more reliable method you might be able to use JavaScript in Chrome to check for the button.

When the dialog with the button is displayed, right-click on the button and select “Inspect”. This will display the HTML for the button. If you don’t know JavaScript, you can post the section of HTML here in a code block and I’ll try to help.