Hide Macro Group Enable pop-up?

Quick question. Is there a way to disable the little pop-up window that says "Enabled" whenever you toggle a one action macro group? The window is getting in the way of programmed mouse clicks, so I have to add a 2 sec delay to avoid the window.

Thanks!

Jeremy

Hey Jeremy,

Not as far as I know. (Peter will correct me if I’m wrong.)

It you want it to be otherwise then you’ll have to make a good case.

-Chris

My case is that it interrupts programmed mouse clicks while it is still visible. Plus, it’s fairly big and in the center of the screen, so it tends to obscure whatever menu I’m triggering.

Hey Jeremy,

That much is obvious.

You don’t explain why you need to enable/disable the group in your use-case – why that is indispensable to the workflow – etcetera.

If you want Peter to consider making a change to Keyboard Maestro and invest the time to do it, you have to make a strong and thorough case.

-Chris

Hi Chris,

In this case, I’m using the macro group as a “sticky key” so that I can nest multiple macros off of that trigger. So for instance, I press [ctrl]+[opt]+[L] to trigger the macro group, and then I have 8 different macro variations for different menu settings. So, if I quickly trigger the key presses, the macros won’t click correctly unless I add a 2 sec delay to avoid the pop-up window. This type of thing worked well in QuicKeys, but is annoying to make work in KM.

I found two possible solutions for my issue.

  1. Toggle a palette for one action instead. It doesn’t block the mouse clicks.
  2. There is a “Display toggle” checkbox that you can unclick under the Activate for one action menu. I somehow missed it!