Hot key weirdness on macOS Catalina

I've been using KM for over a year now and I've got lots of great hot key-driven macros that save me a lot of time. Lately, however, I've noticed that hot keys seem to be working intermittently, or at least weirdly.

For example, I had a macro that leaves the Zoom meeting that I'm currently in, resets my window geometries, etc. I assigned that macro to "Ctrl+Command+Option+L", and it worked fine. I enhanced the macro to support Teams as well as Zoom, and I found that, while the hot key still worked from Zoom, it wouldn't work from Teams. I could trigger the macro manually, and the macro worked for Teams, but I couldn't trigger it via the hot key. Fine, I thought, that hot key combination must be eaten by Teams, so I'll chose another hot key. I couldn't find any hot key combination that worked from within Teams.

To simplify the repro scenario a bit, I created a very simple macro that just shows an alert dialog. This macro works fine if I trigger it manually. I assigned this macro to a hot key like "Ctrl+Option+A", and now I find that I cannot trigger this macro via hot key at all, irrespective of the hot key that I assign to it.

So it all smells like there is some other process grabbing/futzing with hot keys on my machine, but I don't know how to debug any further. FYI, I'm using KM 10.0.2.

Any ideas would be appreciated!


Sound like it is related to the macro group setting. Is the macro group only activate for Zoom app only but not Teams app ?



You were absolutely right. I had set that constraint a while back and completely forgotten about it. Thank you!