Hot key with "delete" key delays very long

I use a macro to cancel all running macro with the capslock+delete (with carabiner element) key as shown in the picture.
image
But, I need to press quite a long to activate this hot key.
If I change this hot key to such as capslock+d, it works perfectly fine.
Anyone have the same issue?

I use ⇧⌃⌥⌘K for this (easy to remember for me, as K stands for "Kill").

I just tried changing it to ⇧⌃⌥⌘⌫ and the trigger field wouldn't accept it, so I tried ⇧⌃⌥⌘fn⌫ (which results in ⇧⌃⌥⌘⌦). This kinda works, but I can confirm that KM doesn't really like this as a trigger. Perhaps consider using something else.

Thanks for the comment. In fact, KM accepts ⇧⌃⌥⌘⌦ but you need to press it 1~2 sec.
KM accepted this hotkey a few years ago, but once I updated OS to bigsur (not sure... it's been very long time), it required to press ⇧⌃⌥⌘⌦ a few seconds to recognize it. I also tried ⇧⌃⌥⌘fn⌫ as you suggested, and it works for me. ⇧⌃⌥⌘K also works for me. But, I prefer to use ⇧⌃⌥⌘⌫ since I used this for years.

Ah yes, you're right. I don't know why this is. There must be some good reason for it. @peternlewis?

I would guess the system is processing the key and then giving up if you keep holding it down and which point it triggers the hot key.

I have no idea what the system thinks it wants to do with the key.

Alright...

It sounds like MK developer didn't intend this behavior and some macOS update
made this issue.

Thanks for clarifying it. I may need to try other hotkeys for that.