Hot keys not working

I just installed Ventura 13.5 on an Intel Mac mini 2018

I imported a few Macro we had and everything worked fine

Our Macros are the following key presses:

Command 1
Command 2
Command 3


Everything was working fine when I was launching these Macro from the finder but then somehow when in KM I pressed Command 1 and since then none of the Hotkeys are working now

When I click on the RUN button, the macros work,
but they do not work when pressing any of the hot keys anymore

I tried to reinstall KM, trash the Library/Application support/Keyboard Maestro and restart, uncheck and check the toggle buttons into System Preferences / Privacy & Security / Accessibility but nothing seems to make the hotkeys work again

any suggestions ?

test.kmmacros (3.5 KB)

Resolve whatever Keyboard Maestro is complaining about:


And then use the Interactive Help.

The macro is enabled, in an enable macro group and apparently active based on the image you should, and hot keys have no security requirements, so the macro will trigger if the Keyboard Maestro Engine is running. And then activating Brave should happen and also does not require any security permissions either. So my guess is the engine is not running, caused by whatever Keyboard Maestro is complaining about (the only other common cause for the Keyboard Maestro Engine not running is the annoying SentinelOne “security” software that actively corrupts the Keyboard Maestro Engine).

it was complaining about screen recording not being enabled

I did enable it and it still didn't work

I then created a new Macro to just activate the browser and somehow it worked !

it worked even after I disabled Screen Recording !

thanks a lot !!!!

OK, that wont affect hot keys (but frequently those warnings can indicate underlying problems).

Hard to say what changed. As I mentioned, my guess was the Engine was not running, so just re-launching the editor would resolve that.