Hotkey Can Not Be Set

Hi, I am new for keyboard maestro. I find that I can not set hotkey such as option + letter. Could you give your help? Thanks in advance!

Hi @alon and welcome to this Forum.

If you want to set a hotkey like, Option + a Letter, such as Q, you would do it like this, just pressing and Q at the same time in the highlighted "This hot key" Field:

A good place to start with stuff like this is here:

But looking at your Screenshot again, I am wondering if you are trying to set Tab + a Letter?

Hi Zabobon,
Thanks very much! I can not set a hotkey like this. I only can choose one from pull-down menu.

1 Like

Welcome @alon

  1. Clear the field (click the X),

  2. Press




I try it but it does not work.

Hey @alon,

What version of macOS are you using?

macOS permissions have been buggy since Mojave.

See this:


Hi ccstone,

Big Sur 11.4 Apple M1

Hi @alon - another user had this exact same problem that was discussed here

And a solution was found - it was to do with Accessibility permissions in the Security & Privacy tab in System Permissions. Take a look at post number 5 in that discussion as that may help you.

Hi Tiffle,
Thanks very much!

Turn them on but hot key do not work.

Hot key does not work:

String works:

We’re they already set like that when you went into preferences?

If they were already set then you have to do the following:

  1. Unset them.
  2. Set them.

In other words, toggle the settings as that seems have worked for other users previously.

Yes, I unset them and set them. But hotkey can not work (the others work)

Can you

  • record yourself showing what you want to do using Quicktime or a free app like Giphy
  • Tell us which key/keys do you want to set up?
  • which KM version are you using?

Hi All,

Thanks very much!

I found the reason.

The input monitoring is not permitted for keyboard maestro.

After set is OK, the hotkey works.

Generally, Input Monitoring should not be required for Keyboard Maestro - it is implicit in Accessibility.

My guess is that for those folks that solve the issue with Input Monitoring are just working around failures in the accessibility permissions.

There is no down side in enabling Input Monitoring, so that is fine, but there may be other aspects of accessibility permissions that are still failing.

For 11.4, a general solution that seems to work is:

  • Quit Keyboard Maestro and Keyboard Maestro Engine.
  • Trash the Keyboard
  • Empty the trash.
  • Download a fresh copy from our web site.
  • Use the Finder to move the downloaded Keyboard to the Applications folder (it is important to use the Finder to do this).
  • Launch Keyboard Maestro.
  • Enable accessibility permissions.

thanks very much!

1 Like

Hi All,

None of the solutions above worked for me on Monterey 12.0.1, so in case anyone else is having this problem here is what did work for me.

But first, note that I only installed KM for the first time (on this machine) this morning. The tutorial hotkey worked. Some time later (and after a reboot), I could not set a hotkey, so here I am.

This is what worked: resetting the Accessibility permissions and rebooting.
Instructions here:

Basically, I could not toggle the accessibility checkboxes in System Preferences. After applying the solution in the link, everything works.


@peternlewis – please note post #17 above.