Unable to Type In a Hotkey for a Macro

Hi, I've been using Keyboard Maestro for about 15 years or so, but I have not created a macro in a long time. For some reason, I am unable to input the hot key stroke under "This hot key:" When I type nothing happens. I've been searching around for the answer but couldn't find anything. It seems like there was at least one other similar post with no clear answer. I think it has to do with accessibility, but following the suggestions has not worked either.

Is this a familiar issue?


Which key? Is it all keys, for example a single letter “A”? Or is it some specific keys that might have special meaning?

(I’ve done the latter before now and had to choose a different hot key - but this is probably not your case.)

Generally this means that there is a system-level keyboard shortcut for the same thing.

If you can't type any keyboard shortcut (such as Command+Enter) then that's a sign of a different issue.

1 Like

Any key. I cannot input anything into the field. I also downloaded the latest version of Keyboard Maestro and got the same result. I briefly looked at how I might do it with Javascript, but haven't done any research in that direction yet. I'd rather figure out the issue at hand.

Could it be a system setting?

Ah. Yeah, that sounds like Keyboard Maestro and/or Keyboard Maestro Engine don't have the permissions they need from macOS.

Check System Preferences » Security & Privacy » Privacy » Accessibility:

and make sure that Keyboard Maestro.app and Keyboard Maestro Engine.app are both listed and checked.

If they are, try un - checking them and then re - check them. Because sometimes macOS is a dumb ox.

1 Like

Thank you! I can now type in a hot key. Now I have to figure out how to turn the Keyboard Maestro Engine back on. I can go into the app package and find it there to double click on, but it's not showing up again in the system preferences (it disappeared when I unchecked it before).

type this in Terminal.app:

open -R '/Applications/Keyboard Maestro.app/Contents/MacOS/Keyboard Maestro Engine.app'

and then drag that to the window above, or use the + button

I cannot uncheck Keyboard Maestro.app

Also getting this accessibility error on the engine (now fixed)

Awesome! Thanks tjluoma. I had opened the application package before, using the control key, but I didn't know to drag the Keyboard Maestro Engine.app icon into the Privacy/Accessibility window.

So to sum up, I deselected "Keyboard Maestro Engine.app" and "Keyboard Maestro.app" in System Preferences/Security & Privacy/Privacy tab/Accessibility. Then, I turned them back on. In order to turn "Keyboard Maestro Engine.app" back on I had to drag its icon (found in the application package via a Terminal command: open -R '/Applications/Keyboard Maestro.app/Contents/MacOS/Keyboard Maestro Engine.app') back into the Accessibility window.

I hope this summary makes sense to anyone who might come across it in the future. Thanks again for all your help!


Please share with us what changes you made to fix the problem.

I did what tjluoma suggested in this quote from above (below the screen shot). However, I could not just re-check Keyboard Maestro Engine.app. I had to drag it into the Accessibility window in the system preferences. You can find this app inside the application package. Follow the directions in my summary above.

1 Like

This “drag in” action is new to me. So thanks for that!

1 Like