How Can I Disable Secure Input When KM Is 'Stuck'?

Keyboard Maestro now displays a caution triangle with a "Secure Input Is Enabled" message. Until last week it was running fine. Now I believe it is 'stuck' thinking it is in a password field. No macros will run and the icon does not appear in the menubar.

How can I clear out this state?

I have restarted many times, including trashing and restoring the KM plist file. Still no luck.

(I tried the Terminal commandset posted here and it returns 'false' so I haven't determined a causing-app.)

I am running KM 6.

1 Like

First, you have to understand that it is not Keyboard Maestro “thinking it is in a password field” - it is the system thinking it is in a password field, and enforcing restrictions. This is a system security feature, not something that Keyboard Maestro can “work around”.

See: Secure Input Problem on the wiki.

Apologies — I did not intend to diss KM!

Yes, I know it is a system issue. However, only KM is impacted. I had already seen the Wiki page you reference. In fact, I have already clicked on the ”very good page” link in the article and the nice Smile folks have emailed me back.

I have also visited the KM Forum page link in your reply, which is where I learned of the Terminal commands to try. (I did, and only got a ’false’ result from the script.) So I posted this as a ‘new’ thread on the subject.

At this point I have even upgraded my Mac OS from El C. to High Sierra. However, the problem with KM not running continues after several system restarts. Perhaps it is no longer a “Secure Input” issue?? Are there other things I can try in KM itself to determine what’s at issue?

This is a screenshot of the Alert I received early on. (I have NOT seen an alert triangle since.)

Mini-Secure Input Is Enabled

1 Like

It’s not a problem, it is just important to understand what is going on. It isn’t something “Keyboard Maestro can fix”, it is something that needs to be resolved by finding the offending process and correcting it.

I’m not sure what you’re saying with this, as it sounds entirely different. If you are no longer having the Secure Input issue, and instead having a different issue, it is probably better to start a new topic.

I kind of am stuck with the same issue, and I am not able to use many apps like Keyboard Maestro and aText. This happened just after updating my MacBook Air from Sierra to High Sierra.

Did you get an answer to this issue, @kah?

The wiki describes the Secure Input Mode Problem and most of the possible culprits and how to go about solving it.

There is no further information, you have to find whatever application (or system process) has the system in Secure Input and resolve it.

Thanks for letting me know. I was able to dig around a bit, and it turns,
Keybase app for Mac was the cause.

1 Like

After running into this issue many times and not finding good solutions short of logging out and back in again, I finally found a terminal command that can help figure out what process is using Secure Input:

ioreg -l -w 0 | grep SecureInput

The output of that command will have a bunch of stuff in it, but the important bit is kCGSSessionSecureInputPID=NNN where NNN is the ID of the process(es) that are using Secure Input.

You can then use:

ps auxww | grep NNN

... replacing NNN with the number after kCGSSessionSecureInputPID= from the first command. This will list the process with PID=NNN.

In my case it turned out to be loginwindow, and killing/quitting that process would immediately log me out of my current session, but as the page linked above describes, locking my computer and unlocking it again (via Sleep) resolved the issue a lot more easily than logging out and back in.

It seems likely to me that loginwindow holding onto Secure Input is an Apple bug.

@peternlewis, it might be a good idea to update the wiki page about this to include the terminal commands, and possibly list the processes in the in-app warning in a future KM release.

Keyboard Maestro does this internally and will tell you what the results is.

However "loginwindow" is a catchall result that is meaningless. It basically means the system doesn't really know. loginwindow is the parent process for all other processes in your user session.

It is probably some sort of daemon or server, often at login, that is causing this behaviour.

Thanks, Peter – I didn't understand that "loginwindow" was meaningless in this way. It's a shame that Apple doesn't make it easier to know what process is actually requiring Secure Input, however I can imagine that exposing that information could open up potential attack vectors.

Mostly though I was happy to find that sleeping and re-unlocking my machine actually resolved the issue, and hopefully that will help others as well.

1 Like

It always helps to search the forum:


Yes, just putting the machine into Sleep Mode (which can be done with the Menu Command Apple→Sleep or by a Gesture or many other ways including making a Keyboard Maestro Macro) and then waking it up again a second later resolves this for me and switches off Secure Input.

From my experience, attempting to first find the culprit App just adds more time to the process and isn't always successful at finding it.

Just wanted to add something which might be useful to others:

I also had the dreaded yellow triangle :slight_smile: But putting the laptop to sleep and waking it up did not work for me. Nor did logging out and in again. Or restarting.

What did work: I'm the type of person who has very many chrome tabs open. Turns out that one of those tabs was a log-in. The website had decided that it needed to prompt me to log in again for whatever reason. And so it was asking me for my name and password on the chrome tab / web page. After I logged in then the dreaded yellow triangle disappeared. Tada!

This is good news and bad news. Good news that I figured it out for my particular case this time. Bad news in that you might have to search through tonnes of chrome tabs in future...