How do I activate the KM Engine?

Seems like whenever I restart the computer the KM engine doesn't start up. And I can't find an intuitive way to start it. Is there a cure?

iMac, Late 2013,
3.2 GHz Intel Core I5, 27”
16 GB Ram, 1TB Fusion HD
macOS 10.14.5
latest version KM

If you check the "Launch Engine at login", then it should auto-launch:


Just launch the Keyboard (KM Editor). This will auto-start the Engine if it is not running.

1 Like

I made sure that it was checked, it had become unchecked, then I quit KM and restarted it. I had accidentally updated to the beta version 9.0d2 and looks like that feature has been removed. Any more ideas?

Robert Poland
Fort Collins, CO

The feature is not removed, but Keyboard Maestro will correct the path of the login item to match the running version when you launch it.

Ensure you are running whatever version of Keyboard Maestro you want to run, and then check the Launch Engine at Login checkbox.

Verify it by looking in your System Preferences, Users & Groups, Login Items - Keyboard Maestro Engine should be listed there (with the checkbox off, since the checkbox means β€œHide” which you do not want - this is quite confusing when compared with other applications lists in the Security & Privacy section). Keyboard Maestro itself should not be listed there.