How Do I Disable RETURN Key for a Specific App?


#1

22%20AM

so this is a screenshot of what I'm working with as of now. Basically what I'm trying to do is make my 'Enter/Return' key not work or become disabled whenever I'm running this application and only have it affect this applications.

If I'm being completely honest I'm brand new to this and I've tried looking through the forums for a solution and haven't found one.

Since I'm new to this a lot of the language and the concepts are also difficult for me so if I could get some help or have someone break it down to a more basic level I would appreciate it.


#2

@stalcant, welcome to the Keyboard Maestro Forum.
Here you will find one of the friendliest and most helpful forums on the Internet. And, you will find Keyboard Maestro to be one of the best Mac automation system.

I hope you don't mind that I have revised your topic title to better reflect the question you have asked.

FROM:
Brand new to Maestro need some help creating a macro

TO:
How Do I Disable RETURN Key for a Specific App?

Providing a succinct, yet descriptive title about your problem/issue will greatly help you attract more experienced users to help solve your problem, and will help future readers find your question, and the solution.

I think I can help you find a solution, but it may be a bit before I have more time available. Stay tuned!


#3

OK, here is an EXAMPLE Macro, and Macro Group, that uses TextEdit as the target app for which to disable the RETURN and ENTER keys.

You will need to change the Macro Group to use the app you wish to use ("League of Legends").

Macro Group

image

MACRO:   Disable RETURN for Specific App [Example]

~~~ VER: 1.0    2019-02-11 ~~~

DOWNLOAD:

Disable RETURN for Specific App [Example].kmmacros (3.1 KB)
Note: This Macro was uploaded in a DISABLED state. You must enable before it can be triggered.


image


Questions?


#4

This works PERFECTLY!!!

Thank you so much!!! I was stuck on just working with Macros instead of creating a separate macro group and assigning the correct macro you have saved me a ton of time thank you so much!


#5

Sorry to have to ask for help again. But everything was working fine originally and now the macro isn't working anymore in the app. I haven't changed anything regarding the actual macro so do you have any idea what may be the reason why it isn't working anymore?


#6

Use the Assistance Window (Help ‚ě§ Assistance) and choose ‚ÄúSomething expected is not happening‚ÄĚ.


#7

In addition to what Peter suggested, think carefully: something MUST have changed that caused the change in behavior of the KM Maco.

  • First, have you done a Mac restart? If not, do so and try the macro again.
  • Have you updated anything very recently? macOS? Other apps?
  • Have you installed or enable new apps or utilities?
  • Have you made any changes to the macOS System Preferences?

#8

No changes made to system preferences. I have installed new apps but nothing that would interfere. I have updated MacOS recently. After I did what Peter suggested it says that the macro group is inactive but I have the macro group checked. Like I said I haven't changed the macro at all so I don't know why the macro group was active before but now it's inactive.


#9

Hey Steve,

You posted a picture of the macro above, now post a picture of the macro group.

-Chris


#10

26%20AM


#11

This is misleading, because when you run the KM Assistance KM is frontmost the Macro Group must be inactive, thus you get this:

image

But if I switch to the target app, "Pages" in my case, then the Macro Group is activated, and I can run the macro. Thus, I get this:

image

Please try that procedure and report back.


#12

So what I did was I clicked assistance had it run and it said the macro group was inactive. Then I clicked on the application but had assistance in the background so I could so if it changed and it still said the macro group was inactive.


#13

In that case, Keyboard Maestro does not think the application is frontmost.

Given you already have two "League of Legends" listed there, I'd guess maybe the app changes name or path, and so Keyboard Maestro is seeing it as a different application.

Reselect it in the editor while it is running.

Keyboard Maestro remembers applications based primarily on paths, and looks for them based on their bundle ID if the application at that path no longer exists.

So if you have multiple versions of the app at different locations (including on different volumes or network volumes) or if the application changes location or path, or if the application is translocated, then the application can appear as a different application.


#14

Ok. So I only need the macro to work on one of the apps. So I removed one of them from the macro group and it still isn't working.


#15

At this point I'd do a little test:

  1. Open only the target app (make sure all of its other versions are NOT running)
  2. Create a new Macro Group in KM
  3. Set the availability for ONLY the target app (should be easy to select since it should show in the "open apps" selection)
  4. Create a new Macro, and put in this new MG, triggered by something simple like CMD-F1
  5. The macro does nothing but display text window
  6. Make the app frontmost, and test the macro

If that works, then move your existing Macro into this new group, and test it.