How Do I Filter by Last Evernote Tag?

To whomever it may concern,

In Evernote, I’m trying to make a simple "filter by (last) tag." The mouse is placed right after the last tag, so I thought I could just do:

Move and Click at (-10,0) from the Current Mouse Location
Show Menu “Filter by Tag” in the Front Application
Or something like that.


I am an awesome fan of KM btw!!!

Brent R. Coyle, M.D.

I hope you don't mind that I have revised your topic title to better reflect the question you have asked.

Stumped and referred by KM support

_ How Do I Filter by Last Evernote Tag?_

This will greatly help you attract more experienced users to help solve your problem, and will help future readers find your question, and the solution.

The problem is that it is the text cursor that is immediately after the tag object.
The actual mouse position may or may not be there, so that is an unreliable reference.

What versions of Evernote and macOS are you running?

I'm still running Evernote 7.14 (458244) on macOS 10.14.6 (Mojave), and have no plans to upgrade to Evernote 10+.

If you're running EN Mac 7.x I can probably help. Otherwise not sure I can.


UPDATED: 2021-03-27 22:42 GMT-5

Here is a simple Macro that works only for Evernote 7.x

Below is just an example written in response to your request. You will need to use as an example and/or change to meet your workflow automation needs.

Please let us know if it meets your needs.


MACRO:   Filter Evernote Mac 7.x With Last Tag [Example]

-~~~ VER: 1.0    2021-03-27 ~~~
Requires: KM 8.2.4+   macOS 10.11 (El Capitan)+
(Macro was written & tested using KM 9.0+ on macOS 10.14.5 (Mojave))

DOWNLOAD Macro File:

Filter Evernote Mac 7.x With Last Tag [Example].kmmacros
Note: This Macro was uploaded in a DISABLED state. You must enable before it can be triggered.

Thank you for the quick response and I'm excited about all of the new ideas to use in KM, but unfortunately, I'm still dead in the water. I am using the "legacy" version of Evernote (7.14.1) on a new M1 processor MacAir. I was particularly excited about the built-in keyboard shortcut of shift-up arrow for selecting. It turns out it actually selects all tags. I knew the shift-command-J option to jump to find a tag. I briefly, was excited that a tag combination might be activated. It seems to not search all notes like the typical "filter by tag" option that comes up with the dropdown. Although a "copy" command seems to capture all the chosen tags, the "paste" doesn't work with the "find a tag." I'm sorry, any other ideas?

Much thanks and respect!


Did you actually try my Macro? I runs fine with Evernote 7.14 (458244) on macOS 10.14.6 (Mojave).

You might need to increase the Pause time. I used 0.1 sec, but you can try increasing it to 0.2 - 0.5.

My macro does NOT use that shortcut. I use SHIFT-LeftArrow, which only selects the last Tag object.

It works fine for me. Double-check you Evernote manually.

Yes, I did try the macro, and when it didn't work, I started breaking it down. One huge issue seems to be the way KM interacts with the Evernote shortcut for shift-left arrow. When I do it manually, it works. That is, it highlights to make it able to copy, but as soon as I try to automate it, it doesn't, any thoughts?
Thanks again for your patience!

Did you try increasing the Pause amount as I suggested?

Thank you so much for your help! I tried the extra pause, and it still didn't work. I've been playing around with other commands, and I'm wondering if it is because the menus are not displayed. It seems no other commands respond because of that same problem. I've tried to simulate the process of exposing the menu items, that is, scrolling up to the top of the screen, and waiting, but I can't get that to work, or find any setting for having the menu items exposed. I really appreciate your time and ideas!


Ok, I finally got it to work, but on my old laptop. I don't know why, but the menu items are visible on my old laptop (that I just got back from getting a new battery today), and not the M1 MacBook Air. I found that using the menu command works better than shortcut menu items. The exception was that I had to use a "click at found image" instead of the menu selection for "all notes." This worked. Any thoughts on the M1 and seeing the menu items?

Select “Edit Note Tags” in the Menu “Note” in Evernote Legacy
Pause for .5 Seconds
Type the ⇧Left Arrow Keystroke
Pause for .5 Seconds
Move and Click at (0,0) from the Center of the Found Image
Pause for 1 Second
Select “Jump to Tag...” in the Menu “View” in the Front Application
Pause for .5 Seconds
Type the Return Keystroke

Hey Brent,

What exactly is and is not visible? Can you provide a screenshot?

What version of macOS are you using on the old laptop?

I should be able to safely assume Big Sur on the M1 MacBook Air, but what version number?

Do you have Automatically Show/Hide the Menu Bar set ON in the General System Prefs.