How Do I Stop Curly/Smart Quotes in the Variables Action?

I use KM to generate some custom HTML. To do this, I set/append HTML to a variable, then write the file. All working fine but if I ever try to edit an attribute value, the double quotes either side of the value change from " to β€œ or ”. This has the unfortunate effect of breaking the page output.

So, is there any way of preventing it from doing this?

Oh - this takes me back a while when I too asked this same question. The solution is in your system preferences as described in this thread

I hope that helps.

Hey Lloyd,

You're probably running into Apple trying to be helpful. See this in the Keyboard Maestro Editor.




EXCELLENT gang! I ran into this today and was copy/pasting from BBEdit to get around it. Love this forum and community.

(How come every time software tries to be "helpful" things get worse?)