How to "Insert text" with line break, without activating send (like in slack)

I have a simple "insert text" action that occurs when I'm typing something.

Essentially when I type:


I want

--------   <--- A bunch of dashes
             <--- A line break
--------   <--- A bunch of dashes

to show up. It's an easy way for me to get an ascii art-ish header.

The problem is that if I have this action set to "insert text by typing" it will hit send in a tool like slack (because the line break is an enter key, which sends in slack). To which you might say "Oh just insert by pasting", which "works" but then it breaks my flow because it now overwrote what I have in my keyboard.

There are only two solutions I see going forward

  1. Figure out how to add a "line break" without enter actually triggering. Maybe there's another character or key combo that could replicate this (i.e. shift+enter in slack won't send a message... it will just actually line break)


  1. switch to "insert by pasting" and add another action that remove the last item in my clipboard, and gives me the item I had in my clipboard before that, the next time I use cmd + v

Does Ctrl+Enter work for you? How about \n ?

Just noticed that the forum changed some of my original question so I'm editing it now.

Just tried ctrl + enter in slack. That works to provide a line break but I'm not sure how to incorporate it into my action.

I also tried \n via ---\n--- with no luck either

Your second idea is perfectly viable; I use it all the time for macros that insert text. As an example:

I have two "delete past clipboard" actions here only because this macro involves modifying the clipboard twice. If you're just inserting text via pasting without copying something else first, one "delete past clipboard" action is all you need.

1 Like

Perfect. Thank you!

1 Like