How to make one mnemonic the default option?

I have three date insertion macros assigned to ALT+D:

Screenshot 2020-07-20 at 10.20.15

How can I make the Japanese date format the default option, that I can select by pressing ENTER?

I'm not sure if there's a way to have "enter" activate the Japanese date, but you can use the number keys to quickly press an item. In this case, you could press "3" to activate the Japanese date.

I personally number items in my macro palettes so I can easily tell what number an item is. Here's an example:

Alternatively, you can use Prompt With List instead of a palette. That way, you could have a default that would be chosen by Enter.

I don't think ENTER will work, but you can just press the highlighted character, in this case th "J" key will trigger the macro.

For the Japanese Date Format macro, simply assign it a Hot Key Trigger to Enter. I have a palette that is pulled up with one shortcut, and assigning Enter as a hot key to one of the presented options worked fine.

Thanks. I tried, but:

  • When you assign a default option, no title is displayed (you just have to guess for the the other options)

  • The macro works in BBEdit but not in Finder to name a folder ...

If you want to see all choices and use the arrow keys to select, then use "all:" for your default.

The trick is to put Japanese at the top, not have the prompt sort automatically, and not use default text or a title. That way, all entries will be displayed and Japanese will be automatically selected as the top entry, letting you press Enter to select it:

As for renaming Finder files as well as inserting the dates in text editors, it's better to use an If/Then to account for when Finder is frontmost and use KM's built in Move/Rename file action accordingly:

Put it all together, and you could do something like this:

Insert Date - Dutch, German, Japanese (default).kmmacros (5.4 KB)

1 Like

Thank you for your help!

I've set the prompt list to automatic width and since I wanted to add the date string to the current folder name, I've made this modification to your macro:

1 Like