How to open a callback URL via keystroke?

I know I'm missing something silly, but I just can't see it. I want to press the F18 key and have Devonthink open to a specific database. When I create this macro and press F18, all I get a sound and Devonthink doesn't open.

SMX Daily Notes.kmmacros (1.9 KB)

Does it run if you trigger it with the Run button inside the Keyboard Maestro editor? Or if you assign a different shortcut?

Edit: Just noticed your trigger. Maybe add a step to make DevonThink the foreground app, then try it from the editor.


Instead of using "Default Application" in your action try using "DevonThink" instead.

Runs just fine from the run button. I did check to see if there was a conflicting hot key, but I can't find one. It seems that no hot key works (I changed the trigger to 5 others).

That was my first thought and I tried changing it. Still the same result.

Well this works fine for me here:

Download Macro(s): __Test Template copy.kmmacros (1.9 KB)


Keyboard Maestro Export

  • Macros are always disabled when imported into the Keyboard Maestro Editor.
    • The user must ensure the macro is enabled.
    • The user must also ensure the macro's parent macro-group is enabled.
System Information
  • macOS 13.6.1
  • Keyboard Maestro v11.0.2

whether I use "Default Application" or "DEVONthink 3".

(I've had to use shift-F18 as a trigger since I'm already using F18 for something else.)

Basically my macro looks to be the equivalent of yours, so I'm not sure why yours isn't working.

I notice that your trigger settings – inherited, perhaps from some group settings – specify that the hot-key is only defined when DevonThink is the front application.

I wonder if you are trying F18 before DT is open, or when it doesn’t have focus ?

1 Like

My macro performs as desired regardless of the state of DT or even whether it's running or not so there's something else going on perhaps?

Bingo! That was exactly the problem. I put the macro in my DevonThink group forgetting the reason for the group. I moved the macro out of that group and now it works perfectly. Thanks @ComplexPoint!

1 Like