How to prevent Command-Shift-V from bringing up Clipboard Switcher

For years, I have Command-Shift-V set to activate the Paste & Match Style feature all of my apps (even if that’s not its default shortcut).

Now that I’ve installed KM, that shortcuts brings up something called Clipboard Switcher.

Is there a way to change KM’s shortcut for this, or a way to deactivate the Clipboard Switcher?

Many thanks.

Here’s how to solve it:

  1. Launch KM Editor;
  2. select All Macros in the Group column;
  3. type or paste ⇧⌘V into the search field at the top right of the window (you can also install and use my Glyphs menu);
  4. the Switcher macro will be in the Macros column;
  5. click its Enabled button (top right) to disable it, or change its hotkey;
  6. also, notice that above the Enabled/Enable button is the name of the group that contains this macro, so next time you won’t have to search for it.

Many thanks! Got it. I also deleted all the other default shortcuts for now, just until I learn what each one is for.

Its a difficult balance to achieve - I want some default macros in there to at least give you an idea of what can be done, and yet its problematic changing behaviour just by installing Keyboard Maestro.

The Macro Library enabled me to significantly reduce the number of default macros.

And I don’t really want to have some initial configuration prompt to ask what you want installed and that impacts the first launch experience.

Oh, no worries, Peter. I think you’re right. I just hadn’t figured out what I was doing yet.

When I first installed Keyboard Maestro many years ago I played with the default macros for a little while to see how they worked and what I might like to keep.

I then disabled all of them and slowly re-enabled the ones I couldn’t live without as I built my own.

I kept all of the defaults as examples and only began deleting them when I was pretty certain I’d absorbed how their various actions worked.


1 Like