I am getting strange beeps every time I use KM editor

It’s been happening for a while now and I really don’t know what the cause of it.

But every time I try to create a macro or edit something in KM editor, I hear beeping sounds.

I tried restarting KM engine and this still happens. Not really sure how to debug this further but it is pretty annoying. :disappointed:

1 Like

Hi Nikita,

I don’t know, never heard a single beep in KM Editor.

  • Is this the usual system (error) beep?
  • Since you haven’t mentioned it: Have you also tried to restart KM Editor? Have you tried to restart the computer?
  • In the menu bar of KM Editor go to “Window” and select “Bring All to Front”, to see if there is maybe a window in the background that needs interaction.

Take a look at this:

I had the issue after reinstalling keyboard maestro after I downgraded.

2 Likes

I’ve had the same problem. I hope this has been entered as a bug report?

According to the links in the post above it was rather a usage error while reinstalling/downgrading and the resulting issue was solved by resetting the sync. So, not really a bug.

That is, if you have a similar issue and it can’t be solved like that, I would recommend to send a bug report.

yeah like @Tom said it was a user error and not anything that is on Keyboard Maestro’s side. Therefore this is
not a bug, just a mistake that i have made.

Look in the Editor.log file (Help ➤ Open Logs Folder) and see if anything is being reported.

It may be failing to write an important file (like your macros or a sync file), which might be what is being reported.

I'm having this issue. In the Log File I get: "Preference shared sync write failed."

When I open (/Users/USERNAME/Library/Application Support ) and Get Info, it seems like I have Read & Write permission. Can you suggest a next step? Thanks.

Double-check your Macro Sync file location:

image

Here is my Macro Sync File Path, after hitting the reveal command: /Users/USERNAME/Library/Application Support

That is not a sensible place for the sync file. It is typically in the iCloud drive, or Dropbox folder, or a similar shared folder.

Basically, Keyboard Maestro is complaining every time it tries to write the sync file because it can't write it where you have specified.

Got it. Problem solved. Thank you, @peternlewis. Thanks, @JMichaelTX.

1 Like

I’ve been experiencing this problem as well. It seems to have stopped after I disabled Stop Syncing Macros.

I do not think the real solution was ever posted, so for anyone that comes along trying to solve this problem.

PROBLEM:
Keyboard Maestro beeps constantly when it is open.

TEST:
Go to File > Reveal Macro Sync FIle:
image

If nothing happens, your sync fils is missing, and every time Keyboard Maestro tries to save/sync your macros, it cannot find the sync file and it beeps.

SOLUTION:

  1. Go to Keyboard Maestro > Preferences
    image
  2. In General, uncheck "Sync Macros" and check it again
  3. This should prompt you to choose a new location to save the sync file.
  4. Choose a location that can be accesses by other Macs that use, such as iCloud Drive or Dropbox.

I made a new folder named Keyboard Maestro in iCloud Drive, and saved by Keyboard Maestro sync file there. The beeping has now stopped.

1 Like

That's exactly what I needed! Thank you!