Imac 2015 WI-FI toggle bug (WIFI) - Please HELP

OS Monterey Version 12.7.3 (I updated it to latest yesterday)
Imac Late 2015

Hey KM community, I am really hoping someone can help me out here.

On my Imac Late 2015 I have a bug where I can't toggle the wifi on... it wont even scan for networks. It used to.. I have ethernet so I am using that but now I want to move the computer and need wifi enabled.

I looked everywhere on the internet and I can't figure this out..

I tried the following...

From this link:

  • #2 Reset Wi-Fi network settings

  • #8 Customize MTU and DNS settings

  • Reset NVRAM or PRAM
    Option-Command-P-R : Reset NVRAM or PRAM.

  • Deranked another admin user I have and quit all things in that other user, then used my ONLY admin user to troubleshoot.

  • Force quit everything Activity Monitor

  • I saw something about wireless diagnostics... I cant get that to open up.

  • I also updated the Mac to the latest version, it still didn't work.

  • I deleted the type of network wifi and thunderbolt in the main Location, I made a new location and added those.

  • I disabled Bluetooth

  • tried most of these things with ethernet plugged in and without

  • I deleted the saved networks (my home internet was one of them), since I thought that would trick into finding it again.

  • I also turned on my iphone hotspot in case my network wasnt being discovered for some reason...

  • I tried to manually connect with wifi name and password, (WPA/WPA2 Personal).
    (I am not well versed in networks, maybe I needed to use the IP address instead of the wifi display name.. im not sure)

The problem looks like a software bug where I cant enable the wifi toggle therefore it isnt even trying to scan for networks to join.
Note about the wifi toggle.. in the top right shortcut it allows me to turn it on, but in the system preferences it never reflects that it actually turns on. The system preferences toggle wont work at all..

Something else I noticed, before I click the turn wifi on button it allows me to display the dropdown and it just says WI-FI: OFF, then when I click the turn wifi on button it doesnt even let me click the drop down anymore, it almost looks like it glitches.

I apologize in advance for asking Keyboard Maestro Forum about this but this community has always been so helpful which is why I love all the times I have contributed over the years... and IT kind of is a keyboard maestro thing... without internet, I cant use it for the things I need :wink:

Thank you SOO much in advance. I tried a for a whole day yesterday I cant waste another one.


I wish I had some good advice for you, but it seems you've tried everything possible in terms of troubleshooting. If you have an Apple Store nearby, might be worth a Genius appointment (though I don't know if they charge for those or not).

Short of that, if I were in your shoes and had tried everything you'd tried, I think I'd make a good backup of all my data, then erase and format the drive and reinstall macOS. Draconian, I know, but you've tried so much other stuff that really should have fixed it.


I have a KM macro for toggling WiFi that uses AppleScript. I run an older OS (10.14 Mojave) and I don't know if anything has changed since you're running Monterey, but it may be worth a try. The AppleScript code:

-- Toggle Airport Power On and Off
if (offset of "On" in (do shell script "networksetup -getairportpower en0")) > 0 then
	do shell script "networksetup -setairportpower en0 off"
	do shell script "networksetup -setairportpower en0 on"
end if

This looks promising.. didn't even think of forcing it with a script. Geniussss. Thank you. Will let you know!

Thank you! Yeah I'm normally not stuck like this... a simple bug turned into a monster. Going to try the apple script approach from @NaOH. Im feeling lucky :wink: