Input of Hot Key combination doesn't work

I am a new user and I am still trying to figure out if Keyboard Maestro will benefit my daily activities. Now I've hit the first hurdle: I am unable to input any hot key combination for my very first Macro. The app simply does not accept any input, nothing is happening. Any ideas what could the reason for that?

Are you sure you're typing in the right field to add the Hotkey? The first field which highlights is the search field, the hotkey field is below that. Also what Hotkey combination are you trying?

Hi David,
thanks for the reply. Yes, I am sure I was typing in the correct field and I found other people in the forum who had the same problem. But there was a solution proposed, which actually helped and I was able to sort this thing out. You might want to check out this thread:

There seems to be a problem with Mojave and Catalina, but the solution is pretty easy but not very intuitive. But once you know what to do, everything works fine.



Mojave & Catalina:

You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes, selecting menus, copy/paste, etc), you need to toggle the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again.


Catalina continues the tradition started in Mojave of being difficult with the Accessibility permissions, and I have several reports of people having troubles enabling accessibility for Keyboard Maestro Engine, which is required for many things.

You should report this to Apple using the Feedback mechanism - the more people who report it, the most chance Apple might fix it, though I am not holding my breath.

Thankfully, once you convince it, there should be no further problems. You should be able to remove the Keyboard Maestro Engine entry from the accessibility permissions, then quit and relaunch the Keyboard Maestro Engine (in Keyboard Maestro, File ➤ Quit Engine, File ➤ Launch Engine), and then you should be able to enable it. You probably do not need to restart, and if things are still causing problems you can use the “tccutil reset Accessibility” command to reset the Accessibility permissions.