Insert action by name shortcut not working

Okay. I give up.

The keyboard shortcut for “insert action by name” quit working on me literally overnight. Worked fine yesterday. Doesn’t work today.

Clicking the menu item works just fine, though.

I don’t recall changing anything relevant so I’m a bit confused. I’ve also tried restarting Keyboard Maestro, the Keyboard Maestro engine, and also my laptop itself, all to no effect.

Does anyone have any idea as to what might be happening? I’m about to start taking it out on the people around me. lol

Hey @Quinn,

Have you installed anything on your system that might eat the keystroke?

Could you have created a macro that uses that keystroke?

  • Go to the “All Macros” group.

  • Select – View > Sort Macros by > Date Used.

  • Select a macro for editing if one isn’t already selected.

  • Type A

  • See if a macro doesn’t sort to the top of the Keyboard Maestro Editor.

If that doesn’t do anything then create a macro with that keystroke trigger that does something harmless and test it. See if it runs or if the keystroke gets eaten.

Take a look at the Keyboard Maestro Engine log in the

See – Help > Open Logs Folder

Your issue is unlikely to be glitch in Keyboard Maestro, since you’ve restarted KM and your system. So look at anything and everything you might have done to cause the problem.

This at least gives you a place to start.


1 Like



That operation caused an empty, untitled macro with that key combination trigger to pop up to the top of the list. Haha! No idea when i might have created that.

Super cool trick. I see myself making use of it again in the near future.

Much appreciated! Thank you.

The Help ➤ Assistance window can help with this sort of problem - either Something expected is not happening, or Something unexpected is happening (in this case, despite your issue being that the key is not working, it’s actually the second case).