Insert text wrongly duplicated in Evernote

I am having this problem using Evernote 6.12.2 with Mac Sierra 10.12.6:

I have created a KM macro that expands the text "rel;" to "relationship"; and another that expands "Rel;" to "Relationship"
(I used to have a single macro that looked at the case of this trigger and expanded it conditionally; I replaced it with 2 macros as part of troubleshooting the problem I am about to describe)

This macro (see screenshot) works fine in all programs - except in Evernote.

In Evernote, when I type the trigger text at the start of a line, it works perfectly. But if I type it in the midst of a line, I get this:

"RelationsRelationship" (or the l.c. equivalent if I type the lower case version of the trigger text).

I have tried changing from "match after any character" to "match after a word break" - no difference. I have changed from "insert by pasting" to and from "insert by typing."

Any ideas what's going on - and how to fix or workaround it?

Thanks!

I just tested this in Evernote 6.11.1 (455059) on macOS 10.11.6, and it worked fine.
I tested it in a new note which had only a few words I just typed before the test.

Example Output


My Test Macro

Perhaps it is a problem with either or both the latest versions of Evernote and Sierra.
I know EN Mac 6.12.2 has a number of issues. I'm still running 6.11.1 until Evernote can release a GA version that has no material bugs.

Thanks so much!

I tried to downgrade EN to 6.11.1, but I got a message about “your data is being managed by a later version of EN”, so it didn’t open.

If this is a bug in EN 6.12.2 - or an incompatibility with Sierra 10/12/6, I’ll have to wait for upgrades, I guess.

But here is another piece of data on this bug:

Interestingly, when I typed my script trigger, “rel;” multiple times on the same line, I got a series of different results. Here is what happened on two consecutive lines in the same note:

relationship rrelationship relationsrelationship relationship relationsrelationship relationship relationship relationsrelationship

relationship relationsrelationship relationsrelationship relationship relationsrelationship relationship relationship relationsrelationship

Note that the same trigger was expanded in three different ways:

“relationship”
“rrelationship” and
"relationsrelationship"

Does that give anyone any clues about the problem?

Doug

If you still want to downgrade EN Mac, see this:
How to Completely Remove and Reinstall EN Mac

Thanks!