Inserting Text in Outlook by pasting adds unwanted space

Hello everyone,

I have hotkeys set up to type German umlauts (ä, ö, ü) more easily.

This solution works well, except for when I'm writing emails in Outlook. For some reason, there are spaces added before the character in Outlook. This doesn't happen in any other app.

Does anyone know why this happens? I appreciate your help.

I'm using 'Insert text by pasting' instead of 'Insert text by typing' because the typing option doesn't type out the actual characters.
Please let me know if you have tips for typing out Unicode characters like Ä, Ü, or Ö with hotkeys.

Hi @weckmann,

Try insert by typing.
Insert by pasting adds a space in some apps.

Edit: sorry. I did not see your last comment.

In that case, you probably have to add further actions for apps like outlook to move cursor, delete the space, and then move cursor back.

I just tried insert by typing. It works as expected. Not sure why it does not work for you.

2021-09-06 14-01-51.2021-09-06 14_02_11

1 Like

Hi @martin ,

It works for the lowercase umlauts but sadly not the uppercase ones (Ä, Ö, Ü).

After a lot of trial and error, I found a solution.

  • First, I tried 'insert by typing' with the %hex% values instead of the characters, but that didn't work.
  • Then, I tried 'insert by pasting' with the umlauts' hex values, which works perfectly in Outlook and other apps. There are no additional spaces when the hotkeys are set up like this:

Thank you for your help!

Here is the macro group for German umlauts (ä, ö, ü, Ä, Ö, Ü):
German Umlauts Macros.kmmacros (8.2 KB))
You can type any umlaut by using ⌥ + A, O, or U.
For uppercase umlauts, use ⌥⇧ + A, O, or U.

Interesting. It works perfectly for me:

2021-09-06 17-05-01.2021-09-06 17_05_17

But I'm glad you've found a workaround solution.

Does your keyboard create umlauts by typing ⌥U + A, O, or U?

I've read in other posts that 'insert by typing' with Unicode characters works for some users, but not all. I'd love to find out why that is.

No. I typed them by long pressing the a, o, and u keys. Of course, use shift as well for upper case letters.


I also tried Opt + Shift + A for Å and it still works perfectly.
Maybe the issue with your settings, such as Accessibility?


Maybe, but I wasn't able to figure out a solution. I ended up creating my own custom keyboard layout.

I've seen multiple posts here from users that can't use Unicode characters the same way you can. In my case, it could be that Apple just assumes that I want the international layout since I have German set up as a secondary language – both the U.S. layout and U. S. International PC are the same for me.

I hope using Unicode characters in Keyboard Maestro will be possible for every user in the future.

Thank you for your help!