Is there a Macro I can set up to send switcher to Hades forever?

I’ve never used the swithcer parts of KM. I have enough of those kind of things built in or parts of other apps. In the last few days it’s started popping up everywhere. I find all kinds of ways to activate about 20 different switcher features but nothing to banish it from my world or just tie it up in the basement and leave it there. Maybe I’ve got some messed up prefs or something. I’ll try a fresh install before I complain any more. Other than that there’s never anything to complain about with KM. So Excellent.

I would say so.

Activating the Keyboard Maestro switchers is just an action, normally there are a handful of macros in your Switcher Group that active the various Keyboard Maestro switchers. You can disable or delete or adjust their hot keys as appropriate. If you are still getting the switchers popping up then I would guess you have accidentally added an Activate Switcher action into one of your other macros.

Note that if you are not using a clipboard history of some kind, you definitely should be, so while disabling the other switchers is perfectly sensible, disabling the clipboard history switcher is only sensible if you are using some other clipboard history solution.

Hey Gregg,

That's generally (but not always) a waste of time.

Go to your All Macros group.

Search for “switch enabled:yes”

You should be able to find the offending macro(s) and turn it/them off.

When troubleshooting Keyboard Maestro the first things to try are:

  1. Quit and restart the Keyboard Maestro Engine (there's a menu item for this).
  • Quit and restart the Keyboard Maestro Editor.
  • Reboot if steps 1 and 2 don't help.

Also see the troubleshooting guide.