iTerm2 reports crash when KM exectues a "Quit a Specific Application" action

I am working on scripts to clean up my desktop - and noticed that iTerm2 doesnt seem to like it when KM asks it to quit. To debug this, I created a simple one action macro. Image attached..

Is anyone else seeing this issue?

Hi, @trickyslip. I'm not seeing this issue. I have:

  • iTerm2 Build 3.4.20
  • Keyboard Maestro 10.2
  • Ventura 13.5.2 (22G91)/MacBookPro16,1

You might try running the following AppleScript in the Script Editor or Script Debugger:

If that works, you might try putting that in an Execute an AppleScript action.

If all else fails, you could try this:

Download: Quit iTerm2 (an indirect method).kmmacros (3.1 KB)


  • Macros are always disabled when imported into the Keyboard Maestro Editor.
    • The user must ensure the macro is enabled.
    • The user must also ensure the macro's parent macro-group is enabled.

System Information
  • macOS 13.5.2 (22G91)
  • Keyboard Maestro v10.2

1 Like

I haven't uses iTerm in decades, but I would try what _jims suggests in Script Editor:

tell app "iTerm" to quit

Which is basically all Keyboard Maestro is doing really.

Then the next step would be looking at the diagnostic report and seeing it it makes any sense and or asking the iTerm folks.

Thanks @peternlewis and @_jims for your quick response. I tried the same test on a different mac and didnt see the crash behavior. Based on your reports, and this test, I'm convinced its an issue with the specific mac configuration and not KM. I'll report back if I find anything interesting. In the meantime, you can consider this issue "solved" :slight_smile: