Just Upgraded to Mojave and Nothing Works -- Solved!

I just upgraded to Mojave and Keyboard Maestro doesn't appear to work at all. I first noticed that I couldn't replace a new Hot Key Trigger. When I hit the keys to set up the hot key, nothing happens. Now I realize that none of my hot keys work (or at least the few that I've tried). Does anyone have any insight into this??

The main upgrade issue seems to be a lack of accessibility permissions (even though they are apparently ticked). The primary symptom is typically not being able to type keys from Keyboard Maestro (ibncluding Command-C/V for Copy/Paste actions). Things to try include:

  • Toggle the Accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and on again.
  • Restart
  • Quit and Relaunch the Keyboard Maestro Engine
  • Quit Keyboard Maestro and Keyboard Maestro Engine and run the Terminal command “tccutil reset Accessibility” and relaunch Keyboard Maestro.

Thanks! Toggling the accessibility permissions seems to have done the trick! I had to Google this to be reminded how to do it. For anyone else who needs help, check out this wiki: http://bit.ly/2xThS6S.


Solved my trouble. The toggling did it.

Much thanks.

1 Like

where do I toggle Accessibility permissions?

See How macOS Mojave Privacy Protection Works


The toggling did it for me also. However I noticed in the Macro that the F key assigned does not display, but if you select it the F key assigned shows up.