KBM Engine Keeps Crashing

Recently (in the past week) KBM Engine has been quitting constantly. I had this happen once or twice before, but a reinstall or a restart always resolved it.

I tried a number of troubleshooting steps, looked through the Interactive Help, etc.

I also tried uninstalling and re-downloading + re-installing the app maybe 5 or 6 times as well.

Re-installing always works, but only for a few mins (maybe 5-10 mins?) before it quits and then needs to be re-installed again. After it quits for the first time, then it cannot be started again (works for a few mins, then never again until re-installed).

Everything but the Engine & the Palette works fine -- I can see all the Macros, they just don't run.

I looked in the logs and saw a lot of these errors:

2022-11-29 10:08:08 KMApplication::LaunchEngine error Error Domain=NSCocoaErrorDomain Code=256 "The application “Keyboard Maestro Engine” could not be launched because a miscellaneous error occurred."
UserInfo={NSURL=file:///Applications/Keyboard%20Maestro.app/Contents/MacOS/Keyboard%20Maestro%20Engine.app/, NSLocalizedDescription=The application “Keyboard Maestro Engine” could not be launched because a miscellaneous error occurred., NSUnderlyingError=0x600000fc55c0
{Error Domain=NSOSStatusErrorDomain Code=-10810 "kLSUnknownErr: Unexpected internal error" UserInfo={NSURL=file:///Applications/Keyboard%20Maestro.app/Contents/MacOS/Keyboard%20Maestro%20Engine.app/}}}

Any thoughts or guidance would be appreciated.

First thought would be: What version of the macOS and KM are you currently running?

Second would be: What, if anything, changed on your system a week ago?

12.6 / Monterey

Nothing I'm aware of, using the same set of tools, and my KBM setup remained the same.

I checked all my Accessibility settings etc.


My guess would be you are running SentinelOne and it is corrupting the Keyboard Maestro Engine.

For reasons known only to them, SentinelOne blocks the Keyboard Maestro Engine and actively corrupts it.

If you aren't running SentinelOne, then I would start by looking at any other security software you have installed, but so far it has always been SentinelOne that causes the problems.