Keyboard Maestro and Remote Desktop

Hello,

I’m a new user to keyboard Maestro and I have tried to set up a macro to type out some text. My macro works fine on my local machine but when I try to use it on Remote Desktop it doesn’t execute any character that require the shift key. For example instead of @ I get a 2 and instead of an R i get r.

I’ve tried doing a Type a Keystroke action as well as a Insert Text by Typing action to execute my keystrokes and neither have produced the wanted results. I also have no issue actually typing @ or R in the remote desktop.

Is there anything you guys can suggest to assist with this issue? I am using Keyboard Maestro version 7.0.3 for Mac.

HI gravid,

Is Keyboard Maestro installed on the remote machine - or only on the local machine - or both?

Conflicts can arise in the keyboard assignments if Keyboard Maestro is running on both machines and similar keyboard equivalents are used. If you suspect this, you might turning off the Keyboard Maestro engine or your local machine when you are using Remote Desktop to work on your remote machine to see if that eliminates your “shift key” issue

I’m having the same issue, v7.3 installed on my local machine, KM is not installed on the remote. A macro using Insert Text by Typing to a remote machine via Apple Remote Desktop results in characters randomly changing from uppercase to lowercase and vise versa. Sometimes it works perfectly, but other times the remote computer won’t receive the correct case after multiple attempts. It’s as if the shift key is randomly being used.

Since this is being used to send the initial login password, installing KM on the remote machine it’s really an option.

Using Set Action Delay to slow down the typing speed has no impact. I’ve even tried sending each part of the password as a separate substring and keystroke, characters still randomly change their case.

Thanks,
Max

I have same problem. Keys modified by shift are not passing through. I am not seeing “random” behavior seen by maxwellk2. Consistently, any text requiring shift key (such as ABC!@# etc.) will not type correctly, instead typing as the non-shift equivalent (abc123). This is KM 7.3.1 and Microsoft Remote Desktop Version 8.0.36 on macOS Sierra 10.12.2.

This is happening to me, as well! KM 7.3.1 on local machine only. Anyone find a fix or work around for this yet?

Hi… This is happening for me. This is October 2017 now. It works with a very old version of RDC, but I need a new 8.x version to connect to work machines. They do not have any KM on them.
Anyone have any fix? I am going to have to use a different product if not :frowning:

Unfortunately, some applications like screen sharing, emulators, or some games or cross platform applications, may look at events or the hardware keyboard or other low level facilities below what Keyboard Maestro can simulate. With these kinds of applications, there is rarely anything I can do to make them work better - the events are simulated through the normal event queue, but how the applications then behave is beyond my control, and usually beyond any ability I might have to come up with a work around.

1 Like

FYI, this issue seemed to resolve itself at some point, not sure if it was just on my end, a specific KM update, or a macOS update. However, it's cropped up again after migrating to macOS 10.15.1 running KM v 9.0.3. Seems like the SHIFT key is not being recognized or sent, same issue in both Apple Remote Desktop and Microsoft Remote Desktop.

Did anyone find a specific fix or workaround?

Thanks,
Max

Found a workaround using AppleScript...

https://github.com/EugeneDae/Force-Paste

Here's the KM macro...