Keyboard Maestro icon greyed out in toolbar

Hi there,

Out of the blue, the keyboard maestro icon is greyed out in the toolbar. I did do a search for greyed out toolbar btw.

I’ve had the yosemite accessibility issues, and dealt with them and it was working fine, then suddenly this, out of the blue. Macros not working either, which is a shame, because after a couple of years of not using KM, I was getting back into it and enjoying it.

I’m still using 4.3.2, and Yosemite 10.10.2

Any ideas?
Best regards,
Damian
(that used to be a macro!)

Hey Damian,

The most basic troubleshooting steps are:

  1. Quit the Keyboard Maestro Engine.
  2. Quit and restart the Keyboard Maestro Editor (which will restart the engine).

* You can restart the engine without restarting the editor, but when having problems it’s a good practice to restart both.

If 1 & 2 fail:

 3. Reboot.

If that fails refer to this troubleshooting guide.

On rare occasions I have had to reinstall the Keyboard Maestro app, but I would be reluctant to do this on Yosemite due to accessibility bugginess. I still haven’t upgraded to OSX 10.10 for that and other reasons.


Best Regards,
Chris

Thanks Chris,
a simple reboot did the trick. I should have tried that first. I actually couldn’t seem to quit the engine as it was greyed out, and restarting KM Editor wasn’t doing the trick. Anyway, all sorted.

I’m going to go write some awesome macros.

Best regards,
Damian
(that was written with a macro this time!)

Hey Damian,

You need not do this from KM’s Menulet. Within the {File} menu of the Editor lies the ability to quit and relaunch the engine.

If for some reason that fails you can run this line from the Terminal:

killall 'Keyboard Maestro Engine'


Best Regards,
Chris

10.10.2 appears to resolve the Accessibility settings problems. At least I have a couple reports of it resolving the problem, and the number of questions about it has dropped dramatically since 10.10.2, so it looks good.

It sounds like the Keyboard Maestro Engine was locked up. There are some cases where clipboard API bugs can cause a lockup in the Keyboard Maestro Engine that have been worked around post Keyboard Maestro 4.x, so its possible you ran afoul of that. If the engine is locked up, you can launch the Activity Monitor utility, get a sample of the problem, and force quit the Keyboard Maestro Engine. Getting a sample of the problem would help me resolve it, although frankly if you’re running 4.x, its not worth your time reporting a problem as I can’t fix 4.x, and any problem is like fixed or different in 6.x.

If it happens sporadically, @ccstone’s killall ‘Keyboard Maestro Engine’ suggestion will be an easy fix.

Thanks @peternlewis and @ccstone. Was just writing to say If the problem reoccurs I’ll probably just upgrade, now that I’m starting to use KM more regularly again. Then I saw it has reoccured! I’ll probably just upgrade. :wink:

Force quiting through activity monitor also instantly fixed the issue, a lot quicker than a reboot. I’ll sort it out one way or another.

Glad yosemite has sorted out its issues. Many thanks, and

Best regards,Damian