Keyboard Maestro Inserts Random Characters

I am getting randomly inserted periods (.) when using Keyboard Macro 8.0.4 on a MacOS Sierra 10.1.6.

Hey Derrik,

Open the Keyboard Maestro Editor.

Select the “All Macros” Group.

Change the sort to “Date Used”.

The next time you have one of these “random” inserts look to see what macro ran last.

You might review the troubleshooting section of the wiki too.


First thing is to confirm that KM is causing or contributing to the issue.
Stop both the KM Engine and the KM Editor app, and see if the issue continues.

You can also review the last few entries in the KM Logs:
GoTo menu Help > Open Logs Folder, or just open this file:
~/Library/Logs/Keyboard Maestro/Engine.log

I don’t know that this is the issue in your case, but I had a similar issue a few months ago where I was getting randomly typed “q” no matter what app I was in. Turned out to be an issue with the Logitech Control Center. After I removed the LCC, I know longer had the issue.

For more info see:

A co-worker discovered that this is caused by a keyboard setting in MAC.

  1. Go to System Preferences > Keyboard > Text
  2. Uncheck Add period with double-space.

Thanks to all for your suggestions.