Keyboard Maestro missing key strokes in macros in Catalina

Hey just recently updated to Catalina and am having an issue where keyboard maestro will miss key strokes in macros. It seems inconsistent as to when it misses keystrokes, is this an issue caused by the accessibility permissions or something else (Still using KM Version 8.2.1)

If it is only occasional keystrokes, it is unlikely to be a permission issue. It is more likely to be related to timing and/or the target application (for example, web browsers (specific web pages really) are notoriously bad for reading and writing fields when you type resulting in lost characters if you type quickly).

Upon further testing it appears as tho KM is skipping pauses entirely, I added 3 10 second pauses (one between each keystroke) to test whether the action was running too fast or skipping keystrokes. When running the action it blew right threw them. For context the action is running in Photoshop, the action activates the place file menu option and using keyboard shortcuts to search for path of file and place in document.

Keyboard Maestro is not skipping pauses in general, so other things are going on. I have moved this to a new topic as this likely has minimal to do with Catalina and more to do with your macro.

Maybe the pauses are disabled, or maybe the macro you are actually running is not the one you are editing, or maybe saving the macros are failing. You will need to provide more information on the actual macro to get an answer.

Add Log action around your Pause actions and then examine the Engine.log file (Help ➤ Logs Folder) to see the times of the log entries to verify that the macro is executing, and what timing is happening.

Post your macro (or at least the parts that are relevant to this discussion).