Keyboard Maestro no longer seeing Stream Deck button presses

I have been using multiple Stream Decks with Keyboard Maestro for almost a year now and everything has been working great until today. Now it seems that Keyboard Maestro can no longer see any button presses from the Stream Deck and pressing the buttons on the Stream Deck displays an exclamation point over a yellow triangle briefly on each button.

I tried creating brand new macros as well as using my existing ones. In all cases Keyboard Maestro appears to be unable to see button presses from the Stream Deck. My macros still run as expected by pressing the Run button in the Keyboard Maestro Editor, with the exception of no longer updating the icons on the Stream Deck itself.

I tried out the KMlink project on Github, and that works, but I need to use Keyboard Maestro since it has the ability to change the button's icons from the macro.

Does anyone know how to troubleshoot this issue? Losing access to all of these macros id going to significantly complicate my workday.


1 Like

The only times I’ve ever had an issue with this I was able to resolve it by simply quitting and restarting the Stream Deck software. It may seem a silly question but have you tried that?

Edit: I think one time I had to unplug the SD and plug it back in too…

Yes, I've tried that. As well as updating the Stream Deck software and updating the firmware on the Stream Deck unit itself.

Turns out a reboot of the Mac fixed my issue. I should have tried that earlier.

1 Like

Well at least it was still something simple!

I too prefer Keyboard Maestros native integration to KMLink because of being able to send info back to the buttons.

This issue has returned for me upon reboot. Another reboot did not fix the issue.

Upon subsequent reboot I unchecked "Reopen windows when logging back in" and the problem has resolved itself again.

1 Like

Very odd! But glad you were able to resolve it.

@dps281 hey I am curious about something. I noticed that my Stream Deck keys are kind of hit or miss since updating to KM10. I wonder if it has anything to do with the added USB Device Key triggers? I temporarily set up a couple of my SD keys with two triggers, "pressed" and "tapped" to see if that makes a difference or me.

Not sure what's causing my issue. It appears I neglected to mention that I can tell right away if the issue is going to occur because many of the buttons on my Stream Deck show the Keyboard Maestro icon instead of the custom icon. Those particular buttons' icons are controlled by the macros directly, not the Stream Deck config UI, so it makes sense that if the connection between the Stream Deck and Keyboard Maestro is broken that it wouldn't know what icon to show. I'm still running KM 9.2.

That's interesting and doesn’t sound at all like my issues. 🤷🏻