Keyboard Maestro not working over Screen Share


I just upgraded Mac OS to Monterey 12.6.2. I had been enjoying simple commands (like command-Tab) to flip through launched apps on a networked Mac through Screen Share.

Now, when I invoke command-tab, it only flips through the apps on the host machine, not the networked one as before.

Is there a setting to go back to that old behavior without downgrading the OS?

KM 10.2 2013 Mac Pro (trashcan) 64 Gb RAM

You can disable the Keyboard Maestro Application Switcher (the macro controlling it is in the Switcher Group) and use the system one.

I don't know of anything about including Screen Shared applications in the application switcher though, Keyboard Maestro certainly doesn't do it, and I wasn't aware that the system one does it either.

If you want to use the KM App Switcher to flip through apps on the remote Mac you'll need to

  1. Install KM on the remote Mac (if you haven't already)
  2. Make sure the Switcher Group is enabled on the remote Mac
  3. Set the Switcher Group on the local Mac to be "Available except in these applications" and add Screen Sharing

That should let the local KM ignore the ⌘⇥, which is then passed to Screen Sharing, which then triggers the KM App Switcher on the remote Mac.

Should, because passing keystrokes to remote machines can be tricksie. See how you get on.

1 Like