Keyboard Maestro sending a phantom command?

I use KM inside Avid Media Composer to map some commands that MC itself won’t map. So I have a simple keyboard maestro macro that sends Shift-Up Arrow whenever I press CMD-Up Arrow.

The problem is… KM seems to be sending something EXTRA, and whatever it is is turning off a particular edit mode in Media Composer that I need to always be enabled. And this is relatively new behaviour… I’ve used KM with MC for years and never had this problem.

To try and troubleshoot, I turned KM off and pressed Shift-Up arrow in MC, and it worked as expected: did not bump MC out of the edit mode. Then I figured perhaps it was because I was still holding down the CMD key in MC at the time KM was sending the Shift-Up Arrow command, and that was resulting in a CMD-Shift-Up Arrow command. So I tried (with KM still off) pressing CMD-Shift-Up Arrow in MC, but it didn’t bump MC out of the edit mode.

It’s ONLY when I use KM to send the Shift-Up Arrow command that something else is causing the machine to get bumped out of this particular edit mode. For the life of me, I can’t figure out how this is happening, or even figure out how to troubleshoot it. But it’s driving me batsh*t crazy! HELP!!!

First, check your Engine.log file (Help ➤ Open Logs Folder) and ensure no other macros are being triggered unexpectedly.

In what ways can you turn off the particular edit mode? What possible key combinations turn it off? Tapping modifier keys? Specific keystroke combinations? In what ways can you manually turn it off if you want to?

What exactly is the macro you are using that is causing the problem? Post it here (use the Share to Keyboard Maestro Forum to post it (see the wiki Using the Keyboard Maestro Forum page)).

Keyboard Maestro “Change Group Up” Macro

Change Group Up.kmmacros (1.7 KB)

The log file shows the single macro press, then with the same timestamp exactly says:
2016-08-04 09:32:49 Execute macro ‘Change Group Up’ from trigger The Hot Key ⌘Up Arrow is pressed
2016-08-04 09:32:49 Assertion Failed: gCurrentExecuteActionListEntry, file: /Users/peter/Keyboard Maestro/Project/Source/Actions/, value: 0

So I did a little more exploring, and found that I had mapped toggling this mode top SHIFT-A inside Media Composer. So I removed that mapping inside media composer, and now when KM sends the command, MC first executes the native CMD-UP, then the SHIFT-UP that KM has sent.

So to recap:

  1. Everything used to be fine.
  2. With SHIFT-A mapped in MC, my KM CMD-UP switches cameras in the clip I'm parked on (expected because KM sends a SHIFT-UP command) but it also seems to be registering a SHIFT-A in MC, thus turning off red arrow mode (unwanted behaviour).
  3. When SHIFT-A is removed from MC mapping, CMD-UP FIRST performs the CMD-UP MC default command (which I cannot turn off... MC doesn't allow it). Only AFTER that, and always AFTER, does KM send the Shift-UP command).

So something changed recently and the default command used to be blocked, but now isn't, but only when SHIFT-A is not enabled. When SHIFT-A IS enabled in MC, the default CMD-UP command is blocked, and this (as far as I can tell) unrelated SHIFT-A command is sent along with the SHIFT-UP.


Firstly, the gCurrentExecuteActionListEntry assertion is fixed in the latest version.

If Keyboard Maestro has a hot key of Command-Up Arrow, and if Media Composer is also handling the Command-Up Arrow, then that usually means that Media Composer is configuring its own Command-Up Arrow hot key.

If two applications both configure the same hot key, the key is swallowed by the system and both applications are notified of the hot key press. If this is the case, Keyboard Maestro cannot block Media Composer from seeing the Command-Up Arrow (or whatever key is configured in Media Composer for this purpose, if it is configurable.

Keyboard Maestro wont be sending a Shift-A - your log does not show any extraneous macro triggering, so the only thing Keyboard Maestro will be sending is the Shift-Up Arrow.

I don’t really know what you mean by “With SHIFT-A mapped in MC”, so it is hard to make suggestions based on that.

What I meant is by the Shift-A mapping is:

When I program MC to perform the edit mode toggle on a SHIFT-A press, my KM macro of CMD-UP does its job, AND the MC CMD-UP permanent native macro is BLOCKED from executing. However, something then goes on to make the edit mode toggle as well. So in this scenario: MC CMD-UP BLOCKED (Good), KM CMD-UP functions as expected (Good), edit mode toggles for some reason (bad).

If I remove the MC Shift-A macro, the CMD-UP performs both the KM Cmd-up instruction AND the MC Cmd-Up instruction, but the edit modes does NOT toggle (which is expected.) So in this scenario, KM-CMD-Up works as expected (Good), edit mode does NOT toggle (expected and good), but MC CMD-UP triggers as well (Bad… but expected according to your explanation, however, this never used to happen. It’s new behaviour).

They have my mac off all internet access, so that’s why its got an old version on it… I just didn’t realise one had come out. I’ll update Monday as see if it helps. I’ll report back.

OK, upgraded to new version and still same results.

What’s so strange to me is that the status of the SHIFT-A Macro in MC should have no effect on the CMD-UP situation, but it does. I can’t figure it out…

I’m afraid the interaction with Media Composer is too intertwined with its behaviour to be able to offer much help.

Keyboard Maestro will not be simulating any extra events, so somehow it is Media Composer is interpreting those events and doing unexpected things. This makes it difficult or impossible to debug without actually having the same setup.