Keyboard misbehavior triggered by...?

(Hey, Peter…long time no speak.)

I’ve also got this same problem running El Capitan 10.11.6, Cintiq 24HD Control Panel and Driver 6.3.16-12, and KM 7.2.
I have a macro, triggered by Control+s then injects a forum signature line (which is about 160 characters of text, no control or modifier keys).
The effect is that, when I run it, the keyboard (from any application programs point of view) goes into upper case. However, when I use the OS X Keyboard Viewer I can see that that the keys are shown in lower case, and the shift key is not stuck down. So it’s something between the OS view of the keystroke and applications’ view of the keystroke that is folding the keystroke to uppercase. I have also observed instances where it appeared that the Command key was “stuck down” as a keystroke modifier.

I have tried killing off the KM Engine process – that does NOT solve the problem – it merely prevents me from forgetting what I’m doing and accidentally causing the problem. The only workaround I have found is to restart the Mac.

For the moment, I have disabled that one particular macro, but I’m concerned that other macro triggers that use Keystroke Modifiers, will also trigger the problem, so, sadly, I’ve had to stop using KM all together.

I’ve not looked at other threads on this forum, so I’m not sure if there is a known workaround.

@Peter: Please let me know if there’s any diagnostic mode for KM or any log files etc. that I can retrieve and send you.

Thanks
Andy

Andy, I’m not sure this will work for you, and it’s hard to test since I can’t trigger the issue 100% of the time, but that said…

Try switching to a different application, clicking on its window, and switching back. That has “unstuck” my modifier key(s) sometimes.

Now, as I’m typing this, I realize that the “other” application I was switching to, also has a different macro group assigned to it, so I’m also switching macro groups at the same time.

I do not know if that group switching is also involved in “unsticking the keys” or if it’s just the change of focus that’s doing it.

Of course, this could be peculiar to my setup too, but I thought I’d toss it out there for you to try, or at least keep in the back of your mind.

hth

One more quantum of information: With KM Engine loaded, I used the Activity Monitor to kill off the Wacom display driver and touch driver. Yahoo! Triggering the KM macro no longer appears to wedge the keystroke modifier to upper case.

Not sure what that says in terms of which code is creating the issue, but at least I can use KM. I’ll only need to fire up the Wacom code when I’m actually doing Photoslopping [sic].

@tvalleau: If the “Wacom Kill” fix doesn’t work, I’ll experiment with what you suggest.
Thanks
Andy

LOL…

Andy: simplying killing (removing in my case: nice to know about the
activity monitor kill) the Wacom driver does indeed remove the issue. I
have reported that to Wacom a few days ago. My test on that is a few
postings up in this thread…

Tracy
www.valleau.gallery

Ooops! My bad, Tracy. I should have read the thread more carefully.
I do recall you wrote that you weren’t holding your breath. I’ve not had much luck with Wacom driver problem resolution from them either.

Andy.

NP, Andy. Good luck to us all! :slight_smile:

Tracy
www.valleau.gallery

Just a quick note to report my experience with the same issue — i.e. sticky modifiers [“keys”]. Some of the suspects that I more or less ruled out :

  • mecanical problem with the keyboard ;
  • weak batteries in the Apple cordless keyboard ;
  • beta versions of
    • Typinator
    • 1Password
  • every Internet Plugins — as the issue seemed linked to browsers usage ;
  • login items
  • preference panes
  • Quick Look plugins
  • Safari extensions
  • Flash
  • Java

A long and tedious process, to say the least ! I say “more or less ruled out”, because, obviously, I haven’t had the time to test different combinations of the suspects ! It had started to remind me of the “good old days” of Conflict Catcher ! :wink: I was desperately wishing a similar tool would still be around !

As I was experiencing the issue on my iMac and not on my MacBook, I even embarked in comparing the two machines’ configurations… still a long and tedious process.

Then I found this thread, after having narrowed my suspicions on “Keyboard Maestro” — but this software has always served me well and I was praying it wouldn’t be the culprit because I litterally can’t work without it !

Finally, YES, I can confirm that :

  1. I had installed Software update 10.11.6
  2. I had a Wacom driver on the iMac and not on the Macbook ! ! !

Deinstalled the Wacom driver and BINGO ! Problem gone ! → I’d rather live without a tablet than without Keyboard Maestro — I’m not a graphic artist.

Olivier :-{)

I am also having this problem since Wacom Driver Version 6.3.16-12.

I have reported the issue to Wacom. If they do not respond or offer a fix in due time, I will go back to an older version of the driver.

For me, logging off and on returns the behavior to normal for some time.
S.

Anyone had any response from Wacom? Seems like their driver might be intercepting the keystrokes and some interaction with KM is causing Bad Things (technical term) to happen.

Peter: Is there any means for turning on diagnostics in KM that might help us isolate this problem? Happy to gather some diagnostic data if it will help.

Cheers
Andy

I understand that Wacom is famously remiss in responding, so I would not
hold my breath.

I can get around the issue by using paste instead of type (although
that’s not always possible).

I tried simply turning off the Cintiq, but that was not a solution
either.

At least for me, it’s either don’t use (long) typed macros or uninstall
the driver.

I’m making do with Paste macros.

Tracy
www.valleau.gallery

I “hear what your not saying” re: Wacom, Tracy.

I think I’ll have to revert to using Paste Macro’s too.

Thanks
Andy

Keyboard Maestro simply sends a bunch of events. It seems the driver is either injecting its own events or mangling the events in some way. In either event, I doubt any debugging info in Keyboard Maestro would help.

Hi Peter:
I was afraid that you were going to say that. I was hoping to provide some additional information to Wacom that would help them diagnose the problem, but I completely understand what you’re saying.

I think I’ll write a bash script, called by cron, that will automagically kill off the Wacom drivers if it finds them running while the Keyboard Maestro Engine process is also running. (I haven’t used pkill in a while and now’s my big moment! :slight_smile: )

Cheers
Andy

The issue is (apparently) moving up the chain:

"Dear Tracy,

Thanks for sending in the detailed notes. I have sent this on to the Driver Team to take a look at.
Michael
Customer Support Team
WACOM"

I just found this thread. I am having the same exact problem. I went so far as to buy a new keyboard as it seemed certain that the old one was the culprit. I went through the process of disabling extension and such with no resolve. Started using the new keyboard today and all was fine, until…it wasn’t. I disabled Wacom drivers for the first time today (after observing some weirdness in system log) and haven’t had any issues since. I had recently upgraded to 10.11.6. This has been driving me crazy trying to diagnose. Glad I’m not the only one and found a conversation to follow for a fix. Thanks for posting. P.S. - I am not using Keyboard Maestro.

Same for me.

There’s nothing quite like finally determining the cause of something like that. I know the feeling!

Hi Tracy,

I have the exact same issue (shortcuts involving ctrl-alt-cmd resulting in ctrl permanently stuck) on my MacMini and my MacBook Air, both of which have a Wacom driver installed. It appeared right after the last Mac OS X update (10.11.6).

Please keep us posted if you find an efficient solution to the problem. I will do the same.

Best

Benoît

Well, 14 days after reporting this issue, I finally got a reply, obviously from first-level support.

They simply suggested I install version 6.3.17-5. Don’t bother trying this, as it still has the issue.
Support does not seem to be aware of the fact that this issue has already been escalated to the driver team as per Tracy’s message above.

Now, what do all these experiences tell us about the quality of Wacom drivers, their QA and their support?