Keyboard misbehavior triggered by...?


OK: I’m pretty sure now that it’s Wacom that is the culprit.

After creating the 189-a’s macro (which is typed) and watching it in
TextEdit with the Wacom driver installed or not, here’s what’s obvious:

  1. with the driver on, the cursor cannot keep up with the typed text,
    and often ends up somewhere within the string when the macro is

  2. with the driver on, the length of the macro is such that anomolies
    will appear, most frequently option-a’s instead of just a’s. I’m not
    sure that it’s just and only the option key however. At one point
    TextEdit crashed; at another the string was broken in half.

If Wacom is sending some kind of modifier at what appears to be random
times, then that would explain why such various things might start
happening in different programs: option (somekey from the string) will
do different things in different programs.

I tried disabling the various function in the Wacom panel for "all apps"
but that had no effect, so it’s some periodic event that the Wacom
software itself is sending, perhaps some “keep awake” or "am I there?"

If this is correct speculation, then I’d further speculate that
switching all my “typed” macros to “paste” would change it. This of
course doesn’t help with those cases where a typed keystroke or phrase
is -needed- unfortunately.

There does not seem to be a way to disable the driver on an app-by-app
basis, and I can think of nothing else I can do as an end user to
rectify the situation, although toggling between apps might restore proper operation. (I’ll keep that in mind.)

Please let me know if I can be of more help, and I’ll post anything
further I find.


Hey Tracy,

People have been having weird problems with the Wacom driver and BBEdit for a few months (that I know of), so you may very well be on the right track.

If you want to know more search the BBEdit Google Group for “Wacom”.


NOW you tell him! :wink:

My guess would be, rather than sending events, the Wacom driver is causing events to be dropped or played out of order.

I have files a case with Wacom support. I am not, however, holding my

Thanks to one and all.


“…dropped or played out of order…” Might be, Peter, but that doesn’t explain a becoming å, or the option-key remaining “locked on.”

when the Wacom drive is installed.

It does when you factor in you are holding down the option key and releasing it at some point, and that while you hold it down, Keyboard Maestro is releasing and re-pressing it to match.

You might try, for example, adding an action:

Pause Until Modifiers are all released

at the start of your macro, that will wait until you release not just the hot key itself, but all the modifiers, which might then avoid or mitigate the issue with the Wacom driver.

Well, I guess I fail to understand how KM works, then. The text of 200 “a” characters is the output. The -trigger- is command-option-control 1. I only need to tap that trigger, (that is, hold down command-option-control-1 for a fraction of a second) and then, with my hands free of the keyboard, watch a parade of "a"s march across the screen. About 2/3 of the was thru that march, around character 140 or so, suddenly the string contains a couple of option-a (å) and then it returns to regular a characters.

If the option key is part of the trigger alone, why does KM need to “release and repress it to match”?

(Hey, Peter…long time no speak.)

I’ve also got this same problem running El Capitan 10.11.6, Cintiq 24HD Control Panel and Driver 6.3.16-12, and KM 7.2.
I have a macro, triggered by Control+s then injects a forum signature line (which is about 160 characters of text, no control or modifier keys).
The effect is that, when I run it, the keyboard (from any application programs point of view) goes into upper case. However, when I use the OS X Keyboard Viewer I can see that that the keys are shown in lower case, and the shift key is not stuck down. So it’s something between the OS view of the keystroke and applications’ view of the keystroke that is folding the keystroke to uppercase. I have also observed instances where it appeared that the Command key was “stuck down” as a keystroke modifier.

I have tried killing off the KM Engine process – that does NOT solve the problem – it merely prevents me from forgetting what I’m doing and accidentally causing the problem. The only workaround I have found is to restart the Mac.

For the moment, I have disabled that one particular macro, but I’m concerned that other macro triggers that use Keystroke Modifiers, will also trigger the problem, so, sadly, I’ve had to stop using KM all together.

I’ve not looked at other threads on this forum, so I’m not sure if there is a known workaround.

@Peter: Please let me know if there’s any diagnostic mode for KM or any log files etc. that I can retrieve and send you.


Andy, I’m not sure this will work for you, and it’s hard to test since I can’t trigger the issue 100% of the time, but that said…

Try switching to a different application, clicking on its window, and switching back. That has “unstuck” my modifier key(s) sometimes.

Now, as I’m typing this, I realize that the “other” application I was switching to, also has a different macro group assigned to it, so I’m also switching macro groups at the same time.

I do not know if that group switching is also involved in “unsticking the keys” or if it’s just the change of focus that’s doing it.

Of course, this could be peculiar to my setup too, but I thought I’d toss it out there for you to try, or at least keep in the back of your mind.


One more quantum of information: With KM Engine loaded, I used the Activity Monitor to kill off the Wacom display driver and touch driver. Yahoo! Triggering the KM macro no longer appears to wedge the keystroke modifier to upper case.

Not sure what that says in terms of which code is creating the issue, but at least I can use KM. I’ll only need to fire up the Wacom code when I’m actually doing Photoslopping [sic].

@tvalleau: If the “Wacom Kill” fix doesn’t work, I’ll experiment with what you suggest.


Andy: simplying killing (removing in my case: nice to know about the
activity monitor kill) the Wacom driver does indeed remove the issue. I
have reported that to Wacom a few days ago. My test on that is a few
postings up in this thread…


Ooops! My bad, Tracy. I should have read the thread more carefully.
I do recall you wrote that you weren’t holding your breath. I’ve not had much luck with Wacom driver problem resolution from them either.


NP, Andy. Good luck to us all! :slight_smile:


Just a quick note to report my experience with the same issue — i.e. sticky modifiers [“keys”]. Some of the suspects that I more or less ruled out :

  • mecanical problem with the keyboard ;
  • weak batteries in the Apple cordless keyboard ;
  • beta versions of
    • Typinator
    • 1Password
  • every Internet Plugins — as the issue seemed linked to browsers usage ;
  • login items
  • preference panes
  • Quick Look plugins
  • Safari extensions
  • Flash
  • Java

A long and tedious process, to say the least ! I say “more or less ruled out”, because, obviously, I haven’t had the time to test different combinations of the suspects ! It had started to remind me of the “good old days” of Conflict Catcher ! :wink: I was desperately wishing a similar tool would still be around !

As I was experiencing the issue on my iMac and not on my MacBook, I even embarked in comparing the two machines’ configurations… still a long and tedious process.

Then I found this thread, after having narrowed my suspicions on “Keyboard Maestro” — but this software has always served me well and I was praying it wouldn’t be the culprit because I litterally can’t work without it !

Finally, YES, I can confirm that :

  1. I had installed Software update 10.11.6
  2. I had a Wacom driver on the iMac and not on the Macbook ! ! !

Deinstalled the Wacom driver and BINGO ! Problem gone ! → I’d rather live without a tablet than without Keyboard Maestro — I’m not a graphic artist.

Olivier :-{)

I am also having this problem since Wacom Driver Version 6.3.16-12.

I have reported the issue to Wacom. If they do not respond or offer a fix in due time, I will go back to an older version of the driver.

For me, logging off and on returns the behavior to normal for some time.

Anyone had any response from Wacom? Seems like their driver might be intercepting the keystrokes and some interaction with KM is causing Bad Things (technical term) to happen.

Peter: Is there any means for turning on diagnostics in KM that might help us isolate this problem? Happy to gather some diagnostic data if it will help.


I understand that Wacom is famously remiss in responding, so I would not
hold my breath.

I can get around the issue by using paste instead of type (although
that’s not always possible).

I tried simply turning off the Cintiq, but that was not a solution

At least for me, it’s either don’t use (long) typed macros or uninstall
the driver.

I’m making do with Paste macros.


I “hear what your not saying” re: Wacom, Tracy.

I think I’ll have to revert to using Paste Macro’s too.