Keypad by Fn + ,jkluio789

I’m desperately looking for a way to get the numeric keypad back into my MacBookPro. Is there a way to do this with Keyboard Maestro?

You can simulate the keypad keys, but not using the Fn key (not with Keyboard Maestro anyway, maybe with a lower level tool). The Fn key is not a modifier that can be used like that.

You could have a macro group that you toggle on and off that turns the jkluio789 into a number pad.

I managed to use the CTRL-key, but I’d really prefer the Fn key. If you’re mentioning a lower level tool, what are you thinking of?

Karabiner (previously called KeyRemap4MacBook) is a low level tool for remapping keyboard keys. It works below the level that Keyboard Maestro does, and can be used to remap keys on the keyboard is interesting ways.

However: Karabiner does not work on macOS Sierra at the moment.

A subset of the functionality is available in Karabiner-Elements.

I know Karabiner. But since Sierra, it is indeed broken. I’m looking for another solution. Karabiner Elements isn’t doing that yet.

Watching this with interest.

Adobe InDesign has a field for setting shortcut keys for Paragraph or Character styles, but it requires (without any info to that effect!) the use of the numeric keypad on an extended keyboard. I’ve seen a couple of forum posts suggesting, you guessed it, Karabiner, but rather than installing it I figured KM would cover it. (And of course I literally only got around to finally upgrading to Sierra yesterday)

Hello - A bit late for an answer but hoping it helps. I’m new to the forum but have been using macros for Mac since the last century. yes - I’m old. I just recently tested a separate keypad - get this - purchased from Walmart for $8. It’s the ONN brand keypad. Oddly enough I did not find this keypad on their web site but it’s in all my local stores (Tampa, Florida). As a side note, iHome offers a numeric keypad very very similar in appearance to the ION brand.

I hate those Fn keys on certain keyboards. I had the same issue and found this keypas did the trick for me.

Using Keyboard Maestro, I can assign any of my macros to this keypad using “DEVICE TRIGGER”. Keyboard Maestro recognizes the keypad as a separate device and does not see it as a numeric keypad once I assign a macro to it.

Here are my specs. I use this same keypad on two different computers running different OSX versions.
Mac OS X 10.7, KM version 5.3.2
Mac OS X 10.9, KM version 6.4.8

A lot cheaper than any other macro keypads I have come across. If you have a label machine, you can use a 3/8" label to create labels for the keypad.

Hope this helps

Looks like this. I found other brand that are similar in appearance but I can't vouch for their functionality. I figure for $8, I could risk it.


I have the same problem with Indesign on a MacBook. I used still today Key Karabiner but now I'm running on OS High Sierra. Karabiner-Elements has changed beyond all and I don't find how insert the feature : Change Num Key, Fn+Number to Keypad in the new app.

Hello, RPerez007,

I do not mind using the Fn key or another key but I'm looking urgently to a middle to simulate the keypad on my Macbook. Once installed Keyboard Maestro, how must I do to simulate the keypad ? I thank you by forehand,


You cannot use the Fn key as a modifier. The Fn key is not a modifier, it is more like a physical toggle for the key that you are pressing to allow the keyboard to have extra keys (eg function keys and hardware brightness/volume keys). It would have been nice it it was just a modifier key, but it's not.

You can simulate a number pad key using the Type a Keystroke action, you can select the number pad keys from the popup menu.

Thank you, very much. Its running correctly. There is only two problems :

  1. The app window (typing cmd+tab) is not usual and is not running so easy than the normal window (see capture in link) Capture
  2. When I type cmd+alt+shift+0 instead of active the shortcut cmd+alt+0 (of the keypad) it close the application
    For info, I'm working on Adobe InDesign.

Thank you by forehand,


These have nothing to do with the Keypad. If you have other questions, you should ask them in a new topic.

If you don't like the Keyboard Maestro application switcher, then you can disable the Activate Application Switcher action in the Switcher Group.

Do you have a macro that is being triggered by ⌘⌥⇧0? If so, disable or adjust it.

Good morning peterlewis,

Excuse me for my bad use of this forum and for the questions asked at the wrong place.
The first question is resolved.
The second was an error from me ; I'm confused to have bothered you for so little. It's now resolved. Thank you for hour patience.
I am convinced for the use of KM on Mac.

Best regards,


1 Like