Keystrokes Not Invoking Hotkeys in Other App

I'm setting up a macro to perform two hotkeys that I've set in a translation app. Those hotkeys work when performed manually, but when I run the macro, nothing happens besides bringing the app into focus. This is my first macro, so I think I'm skipping some key step. Any ideas?

Here's the macro itself.
Screen Shot 2021-01-14 at 8.12.37 AM

Here's the hotkey settings in the other app.Screen Shot 2021-01-14 at 8.13.52 AM

Hey Kurt,

Unfortunately this kind of thing happens sometimes.

What app?

What version of macOS?


Hi Chris,

The app is called Myna for Google Translate. It's a basic translation app similar to the Google one. A free trial version is available here...

I'm using OS X Catalina ver 10.15.7

Is this a case where you need a short delay? I usually start with 0.2s and either increase or decrease it, depending.

Hi Martin,

Thanks for your suggestion. I tried it just now but still no change. I went all the way to 1.5 seconds.

Screen Shot 2021-01-14 at 7.25.28 PM

Hey Kurt,

I monkeyed with it on Mojave.

Absolute no-go with Keyboard Maestro.

Limited success with FastScripts and sending keystrokes with AppleScript and System Events.

Not reliable.

On the whole I like the app, but there're quirks the dev needs to fix.

Too bad it doesn't have AppleScript support.


1 Like

Hi Chris,

Many thanks for going through the trouble. Yeah, it’s a shame because it seems just the kind of app that KM is made for.
Anyway, I’ll try my luck with another translation app.

I'd try asking the dev to make changes too. Some are very accommodating.