KM 11 issue: access data from other apps

I've just upgraded to KM 11. No problems. But ... now every time I try to exit KM I get a message about accessing data from other apps. See screenshot below. I've tried "allowing" and "denying" : both choices end up with me getting the same message everytime I try to quit the app. I get the spinning beachball for about 3-5 minutes before it quits.

I'm using an MBA 15 with Sonoma 14.

What's going on? How do I fix it?

Keyboard Maestro-Keyboard Maestro Editor — BIKE - collapse and expand-10-25 -001052

I don't know if I can help, but I can ask some relevant questions. Have you opened the Security Pane in the KM Editor's Settings window? Did you examine each item and validate that they are all checked? When was the last time you rebooted? When you say "every time I exit KM," do you mean exiting the editor or the Engine? I'm guessing you mean the editor, and if I'm right, tell me what happens when you try to close the Engine instead of the Editor. Does that work correctly? Have you ever changed any options in the General Pane?

@Airy Thanks. Most if not all of those things I tried ... with no luck. But ... today I installed the new Mac OS: 14.1. And that seems to have cured all ills.

Alright. Then this thread is complete.


I'm on 14.1 and KM 11.0, and I'm seeing this prompt a fair amount from the KM editor, and it results in the app beachballing for maybe 20-30 seconds. I have all green checks in Preferences->Security.

A reliable way to get KM to beach ball on my system is to simply try to open the preferences window.

Any ideas?

I had about three ideas above, including rebooting and trying Safe Mode. So you might try those ideas.

Hi @Airy, thanks for your suggestions. I forgot to mention I had tried rebooting and safe mode to no avail. The beach balling did not occur while logged in in safe mode, but it returned when I went back to "normal" mode.

A bit more on this behavior: the "would like to access data from other apps" appears every time I invoke que preferences window using the CMD-, shortcut, not from the menu. The way to avoid the beach balling is to click on "Don't Allow".

Even if I avoid this by not invoking preferences, the dialog pops up anyway every time I try to exit the KM editor as described by @Mathew, but again there's no beach balling if I click on "don't allow".

Then I'm running out of ideas. The conditions that trigger your "permissions" app are different from Mathew's, so maybe you need a new thread, because Mathew closed his ticket (he marked this as "Solved".) If none of the wizards on this site read your unresolved issue in the next day or so, then I recommend you start a new thread so that they can find it more easily. They may not follow threads that are "solved." I don't have quite the same configuration as you do, which means my options are limited.

Will do, thanks.