KM does not work After I Upgraded to macOS Catalina. How do I fix?

I upgraded my iMac to OS 10.15.2 Catalina and KM does not work.
KM icon is on the Menu bar.
I can see all my macros when I open KM Editor.
Please help.

First, please try searching for "catalina" in this forum. Apple make some major changes in security starting with macOS Mojave, and more with Catalina.

And see this in the KM Wiki: Accessibility Permission Problem assistance

If you still can't run/trigger any Macro, then you can ask Keyboard Maestro itself for assistance by choosing Help ➤ Interactive Help menu.

If all of that does not solve your problem, then please upload an example macro and also a screenshot of its Macro Group details.

BEFORE you attempt the next fix, let's see what @peternlewis has to say.


As the VERY LAST fix to attempt, you can try a reinstall of KM:

  1. Export All of your Macros somewhere safe.
  2. Backup these files in the KM Support Folder
    ~/Library/Application Support/KeyboardMaestro
    • Keyboard Maestro Clipboards.plist
    • Keyboard Maestro Clipboard History.plist
    • Keyboard Maestro Dictionaries.sqlite
    • Keyboard Maestro Macros.plist
    • Keyboard Maestro Variables.sqlite
  3. Use an app uninstaller like AppDelete or AppCleaner
  4. Download a fresh copy of KM from Keyboard Maestro 11.0.2: Work Faster with Macros for macOS
  5. Be sure to install in your main Applications folder.
  6. After you start the KM Editor, try creating a very simple macro to test.
  7. If that works, then import all of the macros you exported in Step #1.


1 Like

Keyboard Maestro (9.0.4) has been causing me long hangs it seems in Catalina. These are odd hangs and when I operate the system without Keyboard Maestro enabled in the background I no longer have these hangs. They seem to happen most frequently in Chrome. I can't really explain this well since it is confusing to me, but for the time being I'm just operating without Keyboard Maestro since it causes this strange problem.

Just in case anyone runs into this because they have upgraded an older Mac to Catalina, JMichaelTX first suggestion to review the wiki article went straight to the problem for me. Quitting KM and removing the KM items from accessibility items fixed the issue for me on an old mac I still use quite often.

I had only recently updated it because I wanted to try and maintain a machine with an older OS for specific applications I depend on.

To save you time, here's the note from the wiki:

⚠️ Note that for Catalina continues the tradition started in 
Mojave of being difficult with the Accessibility permissions, 
and I have several reports of people having troubles enabling
 accessibility for Keyboard Maestro Engine. 
You should report this to Apple using the Feedback mechanism. 
Remove the Keyboard Maestro Engine entry from the accessibility
 permissions, then quit and relaunch the Keyboard Maestro Engine
 (in Keyboard Maestro), 
File ➤ Quit Engine, File ➤ Launch Engine) to re-add it, 
and then you should be able to enable it.