KM Editor & Engine both hang when interacting with Chrome on M1

Hi everyone! Longtime lurker here.

I recently "upgraded" to the M1 and noticed that my (previously working) KM browser scripts were not working correctly in Chrome. It seems BOTH the Editor and the Engine hang when interacting with Chrome. The issue does not happen with Safari.

You can test this out by opening Chrome and then launching the KM editor. Create a new macro and add Select Google Chrome Field. Then, click on the Google Chrome dropdown to get the list of fields. You'll likely get the spinning beachball in the editor.

Quitting Chrome releases the stranglehold.

Again, this does not happen with Safari or another browser I've tried (Fluid).

I hope this helps.

I am curious. Have you downloaded the M1 version of Chrome?

1 Like

Excellent question! I had not checked to see which version I was running. I will download the M1 version, test again and will post my results.

Thank you!

Many blessings & stay safe,


Thank you very much for the suggestion. Downloading the latest version of Chrome (for Apple Silicon) no longer hangs.

Thank you for your help!

Many blessings & stay safe,


1 Like

Remember to mark the reply which has the solution, so it is easier for others finding this post to see the solution :slight_smile:

1 Like

You turned on JavaScript from Apple Events in Chrome?



Solution marked. :+1:t3:

Also, yes, I had turned on JavaScript from Apple Events in Chrome.

I had migrated my existing setup to the new M1 and incorrectly assumed everything would just work. Upgrading Chrome to the Apple Silicon version worked great.

Thanks again everyone.