KM Editor → Share → Failed to Upload Image and File

Anyone else having this issue?

See gif below:

2021-09-30 13-02-07.2021-09-30 13_04_08

1 Like

Hi @martin, I can see this on me (Safari 15) as well.

However, to share the KM macros with/without screenshots I use this macro:

2021_09_30_Support_1

01)Macro:A:I <0686 210930T220240>.kmmacros (47,0 KB)

I'm having the same issue for some reason. @peternlewis any ideas?

Hey Guys,

I'm having problems too.

I think Peter broke something while testing.

We'll see what he says when he gets around.

-Chris

Haha talk about timing. I’ve got a macro I need some help with (multi line KM variables inside an AppleScript) and I was gonna use your nifty macro uploaded we were talking about the last few days to post it….guess I’ll wait now :joy:

Thanks a lot for confirming the issue. Let's wait for Peter to fix it.

I use a macro I created myself. It puts the macro file and a screenshot to the clipboard, taking the advantage of the clipboard manager.

By : Martin Zhang
Created : 03/12/2021, 11:37 PM ET
Modified : 09/13/2021, 03:53 PM ET
Version : 1.3

Purpose:
This macro puts the selected macro(s) to the clipboard, ready to be pasted into msg apps.

Comment:
The macro does these things:

  1. Create a folder named "tempFolder" in the temporary folder. (your temporary folder on your Mac maybe different) you may use another directory.
  2. Create a macro file in the temporary folder.
    2.1 If multiple macros are selected, you'll be asked to give a name for the macro.
  3. Another macro (named "Trash KM Temporary Macros") delete the "tempFolder" monthly.

25)Export Slected Macro and Copy to Clipboard.kmmacros (10.4 KB)

Click to see the screenshot

I have another macro to delete the temporary folder monthly:

Trash KM Temporary Macros.kmmacros (5.0 KB)

Click to see the screenshot

2 Likes

It's nothing I broke - I suspect it is the great Lets Encrypt CA Certificate expiry disaster. Lots of stuff broke when the Lets Encrypt authority certificate expired on Sept 30.

That said, I've updated the forum server, and I think that has resolved it.

2 Likes

Works for me as of 2021/10/01 00:35 CDT.

Thanks!

2 Likes

Works for me too as of Friday, October 01, 2021 @ 09:14:08 AM.

Thanks Peter!

2 Likes