KM Link Does Not Work After a Clean Install


  • Mac mini ((M1 2020)
  • macOS 13.4 Ventura bèta
  • Keyboard Maestro 10.2
  • Stream Deck (version 6.2.0 (18816)
  • KM link 1.5

I've performed a clean install on my Mac mini.

After that KM link stopped working. When I press the button on the Stream Deck it shows a yellow exclamation mark and the macro is not executed.

I have no idea what I can do anymore. Who can help me?

Below I've provided some relevant information.

In the SD-software the arrow just keeps spinning.

CleanShot 2023-05-10 at 14.03.16

When trying to make a new action button on my SD with KM link the arrow also keeps spinning and I cannot see a list of Macros.

I've made sure the macro is not in a folder with a palet of something like that. The solution provided in New Stream Deck – KM Link Not Working - #8 by tiffle therefore does not apply.

The macros do work; I've run them manually via KM >> Run.

CleanShot 2023-05-10 at 14.07.32

The Interactive Help shows that everything is okay.

CleanShot 2023-05-10 at 14.27.16
CleanShot 2023-05-10 at 14.29.16

I run a beta, but I ran the same beta-version before the clean install and KM Link worked just fine.

As far as I can see, all neccesary permissions are okay. I've toggled the permissions on and off (via System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and
Keyboard Maestro Engine.

First thing I'd try would be quit and relaunch the SD software. If that doesn't help, quit KM and relaunch the KM engine.

1 Like

You did reinstall the KM link plug-in?

1 Like

I’ve quit/restarted and removed/reinstalled stream deck, KM and KM link. Should have mentioned that in my initial post. :grimacing:

Hi, I read that your post have been slightly more than a year. I had encountered exactly the same situation as you since 2 days ago. I am on my M1 MBA. I do a clean reinstall of MacOS on my laptop, and then this whole scene happened to me.

I am exhausted with finding the solution and exhausted all the options available. The had gone the same path as you after reading you first post.

Have you found the root cause, and what actions and steps you had taken to resolve this? It's very frustrating for me to be unable to use all the macros I've created.