KM not accepting serial

Been using KM fine yesterday.Today it says your trial period is ending. Bought KM nearly 1 month ago
When trying to enter the serial, the register button is still greyed out. Any suggestions how to fix this or is this a new feature?

I’m looking at the email I received with my registration number, and it looks like you need to enter a username as well as a serial number. For me, it shows an email address as the username - in my case, it’s my PayPal email address.

So maybe you’re using the wrong username value?


Sorry for phreaking out…
My work was so dependent on KM so it was really scary when it stopped working.

1 Like

You can get your license details emailed to you at any time by clicking the What’s My License link on the web site:

Ensure you are using a license that matches the version of Keyboard Maestro you are using (so version 7.x license with Keyboard Maestro version 7.x). Generally you can use a version N license with Keyboard Maestro version N-1 (so 7.x license will also work with Keyboard Maestro 6.4.8 for example). If you need an older license that you have, you can email me. If you need a newer license than you have, you can purchase an upgrade or revert to an older version.

Then make sure you enter the username and serial number exactly as shown in the license. Your email address may have changed, but your username will remain unchanged and is linked to the serial number. Generally the license also includes a Register link, and you can launch Keyboard Maestro and then click that link to register.

Check that you are registered by looking in the About Keyboard Maestro. Quit and relaunch Keyboard Maestro and verify that you remain registered (very occasionally preference files can become corrupt or have the wrong permission which can result in your registration being undone when you quit and relaunch).

Hopefully that resolves all problems.

No apologies - I think I'd react the same way!

Can I assume this solved your problem? Hope so. If it did, can you click the checkmark below my post to indicate the problem is solved? Thanks.